[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: jessie won't install/boot on a Dell Poweredge R815

Jeffrey Mark Siskind wrote:

>    I had big issues with mptsas and 3.16 in jessie, so I am still using
>    3.2.0-4-rt-amd64
> Will jessie run with 3.2.0-4-rt-amd64? If so, where do I get it and how do
> I install it on a fresh jessie install that wasn't dist-upgraded from
> wheezy?
>     Jeff (http://engineering.purdue.edu/~qobi)

Yes I run it with that kernel since wheezy. You can get it from wheezy


Here is what I have and bit of background

# uname -a
Linux lisa 3.2.0-4-rt-amd64 #1 SMP PREEMPT RT Debian 3.2.68-1+deb7u4 x86_64

# cat /etc/debian_version

- Disk controller is mptsas here not mpt2sas as you posted - no idea what is
the difference.

- disabled systemd and using old init. When I upgraded (as this is
production machine I tested  upfront as you did - found out I had a problem
with the kernel and did not have opportunity to work on the issue - I don't
have another with this configuration - I just kept the old working kernel).
I later tried to move to systemd as on other machines it worked, but I hit
an issue with the raid and missing root and told the kernel to use the old
init. I just hope debian would keep old initrc style longer and God bless
the wise people there.

# grep init /etc/default/grub
GRUB_CMDLINE_LINUX="ro rootdelay=15 splash quite init=/lib/sysvinit/init

I also do not understand why you should install and not upgrade as you
already narrowed the problem.
I never do a fresh install - much easier is bootstrap + copy (gzip or
whatever), besides this obsoletes the question how the kernel would go
there. Of course this applies only if you can boot from usb. But if you can
boot from usb, you can also "repair" things easier.

I hope this helps


Reply to: