[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Access to repos blocked

On Mon, Mar 07, 2016 at 02:12:59PM +0700, MH wrote:
> Recently ran into a problem with aptitude. I get the following message:
> E: The method driver /usr/lib/apt/methods/https could not be found
> Since I am not using ANY HTTPS repos, I should not be getting the above error. 

Are you absolutely sure?  Check /etc/apt/sources.list.d/* as well as
/etc/apt/sources.list.  apt won't try to use that method driver unless
it needs to.

> Still, after searching the Internet for similar problems I installed the apt-
> transport-https package. I got a different error.

What specifically was that different error?

> I tried to submit a request for help on the Debian forums, but when I tried to 
> register I received a warning that my ISP had been blocked as a source of 
> spamming networks.
> I'm guessing the two issues are related, since I can still access non-official 
> repositories, including Kubuntu repositories (VM) without a problem. While I 
> can sympathize with a need to fight spam, I don't think blocking access to 
> security updates is the best way to go about this.

I think it's unlikely that registration issues on the forums have
anything to do with access to security updates, and it's even less
likely that there's any kind of unified consistent ISP blocking across
all Debian mirrors (there are lots, hosted on a wide variety of
different sites with different administrators).  It's pretty hard to
tell exactly what's going on without the exact text of the error message
you're seeing, though.


Colin Watson                                       [cjwatson@debian.org]

Reply to: