[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Access to repos blocked

Debian Jessie

Recently ran into a problem with aptitude. I get the following message:

E: The method driver /usr/lib/apt/methods/https could not be found

Since I am not using ANY HTTPS repos, I should not be getting the above error. 
Still, after searching the Internet for similar problems I installed the apt-
transport-https package. I got a different error.

I tried to submit a request for help on the Debian forums, but when I tried to 
register I received a warning that my ISP had been blocked as a source of 
spamming networks.

I'm guessing the two issues are related, since I can still access non-official 
repositories, including Kubuntu repositories (VM) without a problem. While I 
can sympathize with a need to fight spam, I don't think blocking access to 
security updates is the best way to go about this.

Since I have only one ISP option (rural Thailand), I'm concerned. I've brought 
the matter to the attention of my ISP, but given the Debian mirrors and forums 
are the only sites I can find (out of about 100 regularly visited) that are 
blocking my ISP, it's going to be a tough sell to get them to do anything. I'm 
sure few if any of their other users are complaining.

Please advise. I'd hate to have to abandon Debian after nearly 10 years of 
daily use just to keep my computers up to date.

"The world is a dangerous place to live -- not because of the people who are
evil but because of the people who don't do anything about it."

					--Albert Einstein

Reply to: