[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem with uefi motherboard.

On Thu, Nov 06, 2014 at 09:29:50PM -0500, Ryan Larrowe wrote:
> My computer won't boot after a fresh install.  Grub says unknown
> file system and starts rescue mode.  I've tried searching some posts
> on the issue but none have worked.  I have a 200MB efi partition
> that I did not set a mount point for.  I read that setting a mount
> point isn't necessary.

A few days ago in another Debian mailinglist [1]
there was this

* boot with debian-installer-usbstick in UEFI mode
* choose "rescue mode" and answer questions
* open a shell at TTY2      ( switch screen with ALT-F2, switch back with ALT-F1 )
* mount /dev/sda1 /boot/efi
* efibootmgr   # to see what your start point is
* grub-install --bootloader-id debian /dev/sda
* efibootmgr  # should now show bootloader ID  "debian"
* exit
* reboot

Please report your mileage.  

Geert Stappers
Not yet familair with UEFI boot proces,
so I want the expriences of others in the mailinglist archive

Foot notes
[1] https://lists.debian.org/debian-user-dutch/2014/11/msg00039.html
Leven en laten leven

Reply to: