[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#705961: installation-reports: debian-installer does not create an EFI partition by default

Hi Steve

Thanks for your help. Yes, I was surprised of this problem because I did not see anything  in the release notes, despite of having some information on the UEFI issues.  Let me extend a bit more on the process followed:

The PC came with Windows 8 pre-installed. That implies also a recovery partition, so grub now "offers" two Windows starts: one for normal Windows, one for the recovery partition (I guess this is standard).  Anyway, I tried to boot from the installation CD of squeeze. I had to do that through the "legacy" mode and deactivated the "secure booting" just in case. d-i did not notice that there were EFI partitions, and installed linux in the space I freed from the disk. No need to mention that I could not boot the linux partition even from the legacy mode.  Then I decided to move on to Wheezy. I "formatted" the linux partition to prepare the new installation (see below)

El 22/04/13 22:05, Steve McIntyre escribió:
On Mon, Apr 22, 2013 at 09:29:57PM +0200, Jorge Sanz Forcdada wrote:
Package: installation-reports
Severity: normal

Hi Jorge,

I must admit that I'm very surprised to see this bug report - I've
written a lot of the amd64 UEFI support code in debian-installer, and
it's been working just fine for me in testing. So, if you could answer
a few questions for me that would help enormously in working out
what's gone wrong here.

1. You say that you want to install on a disc with Windows 8 - is
   Windows 8 installed there already? If so, then the installer code
   *should* pick up on the existing EFI system partition that Windows
   will have created, and use it accordingly I'm guessing you didn't
   already have Windows 8 installed, from the information further

   If it doesn't find an exiting EFI system partition, d-i should
   create one itself automatically.

Yes, Windows 8 was installed before. When I tried the first installation of Wheezy the bios only showed the UEFI Windows boot (and the linux CD too), so I could not boot the new linux installation and decided to repeat the installation preparing a new EFI partition.  The debian installer saw the Windows EFI partition already present in the disk before installation. Besides, I think it recognized (?!) the former linux squeeze partition as an EFI partition (not 100% sure of this).

I must say that during the whole process I kept a doubt about a partition of 1 MB that I believe was created by squeeze, but I prefered not to delete it just in case it was a bios thing   (it still there, it does not bother :-) ).

2. Are you *100%* sure that you booted the installer in UEFI mode? You
   can check this by looking at startup messages as the machine
   boots. If it's booting via UEFI, you'll get a cosmetic complaint
   from grub at early boot: "prefix not found".

I believe so. I certainly had that intention, and I don't think the d-i would have seen the former partitions as EFI if booting in legacy mode, right?  I remember to see that weird message "prefix not found", but I do not remember in which boot. I am sorry I could nto send this report before, I would have this information more fresh in my mind.   I hope it helps, but if you do not receive any similar report it may have to do with the two trials of installation before the succesful one.

Thanks for pointing about the other bug on the grub not booting the Windows 8. I will fix it now. 
I agree with you that the graphics issue is not related, I just mentioned it just in case somebody wants to insist in the installation docs (I think it is written already) about the need of using non-free packages to make some graphic cards to work. Newbies use to be discouraged of using Debian because of this kind of things

Thanks again. Please let me know if I can help further.



Boot method: CD netinst
Image version: debian-testing-amd64-netinst.iso (version 20130417) 
Date: 2013-04-17, 18:00 UT  (20:00 CET) 

Machine: HP Pavillion p6-2306es, Intel core i5, 6 GB RAM
rootfs                                                 rootfs    653954576 156762724   463972884  26% /
udev                                                   devtmpfs      10240         0       10240   0% /dev
tmpfs                                                  tmpfs        608444       664      607780   1% /run
/dev/disk/by-uuid/23716695-21dc-4f05-8429-291f7621f862 ext4      653954576 156762724   463972884  26% /
tmpfs                                                  tmpfs          5120         0        5120   0% /run/lock
tmpfs                                                  tmpfs       2466160       292     2465868   1% /run/shm
/dev/sda7                                              vfat          34260       117       34144   1% /boot/efi

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [O]
Configure network:      [O]
Detect CD:              [O]
Load installer modules: [O]
Clock/timezone setup:   [O]
User/password setup:    [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Install base system:    [O]
Install tasks:          [O]
Install boot loader:    [E]
Overall install:        [O]


- The initial partitions in the "guided partition" of the disk made
 just two linux partitions, the main one and the swap. With that
 scheme I did not manage to boot the system. THen I made my own
 partitions, using ~36 MB for an EFI partition, plus the main
 partition (where / is mounted) and the swap.  That scheme worked
 fine, except for...

- The grub installed almost correctly. It enters to Debian
 smoothly. But when I try to enter to Windows 8 it tells me:

   Error: unknown command 'drivemap'
   Error: invalid EFI file path

 Right now I have to go through the startup menu of the Bios to
 enter Windows 8. I haven't managed to solve this problem myself.
OK, *this* is a known issue that I've reported myself. See
http://bugs.debian.org/698914 for the bug report, and information on
how to work around it.

The question of the guided partition must be solved for the UEFI
systems (I believe this should be easy), or at least a note should be
put somewhere telling how to make your own manual partition.
ACK - I expect the code to already work...

- Finally, the graphics did not work correctly until I installed the
 packages related to the (non-free) driver of fglrx (for AMD/ATU
 Radeon HD series). Before that it displayed some graphics but
 gnome3 was not able to start.
OK, that's an unrelated issue..

Reply to: