[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#705961: installation-reports: debian-installer does not create an EFI partition by default

On Mon, Apr 22, 2013 at 09:29:57PM +0200, Jorge Sanz Forcdada wrote:
>Package: installation-reports
>Severity: normal
>Dear Maintainer,
>*** Please consider answering these questions, where appropriate ***
>   * What led up to the situation?
>     I wanted to install Debian in a disc with Windows 8 inside
>   * What exactly did you do (or not do) that was effective (or
>     ineffective)?
>     The guided partition created a single partition for Linux, while
>     in a UEFI system it is needed an EFI partition to start up. I
>     solved the problem by manually creating a small (36 MB) EFI
>     partition.
>   * What was the outcome of this action?
>     The problem was solved. Otherwise linux does not boot after
>     installation.
>   * What outcome did you expect instead?
>     The guided partition of the installer should prepare an EFI
>     partition in this kind of system, or at least warn the user to
>     do it manually

Hi Jorge,

I must admit that I'm very surprised to see this bug report - I've
written a lot of the amd64 UEFI support code in debian-installer, and
it's been working just fine for me in testing. So, if you could answer
a few questions for me that would help enormously in working out
what's gone wrong here.

1. You say that you want to install on a disc with Windows 8 - is
   Windows 8 installed there already? If so, then the installer code
   *should* pick up on the existing EFI system partition that Windows
   will have created, and use it accordingly I'm guessing you didn't
   already have Windows 8 installed, from the information further

   If it doesn't find an exiting EFI system partition, d-i should
   create one itself automatically.

2. Are you *100%* sure that you booted the installer in UEFI mode? You
   can check this by looking at startup messages as the machine
   boots. If it's booting via UEFI, you'll get a cosmetic complaint
   from grub at early boot: "prefix not found".

>Boot method: CD netinst
>Image version: debian-testing-amd64-netinst.iso (version 20130417) 
>Date: 2013-04-17, 18:00 UT  (20:00 CET) 
>Machine: HP Pavillion p6-2306es, Intel core i5, 6 GB RAM
>rootfs                                                 rootfs    653954576 156762724   463972884  26% /
>udev                                                   devtmpfs      10240         0       10240   0% /dev
>tmpfs                                                  tmpfs        608444       664      607780   1% /run
>/dev/disk/by-uuid/23716695-21dc-4f05-8429-291f7621f862 ext4      653954576 156762724   463972884  26% /
>tmpfs                                                  tmpfs          5120         0        5120   0% /run/lock
>tmpfs                                                  tmpfs       2466160       292     2465868   1% /run/shm
>/dev/sda7                                              vfat          34260       117       34144   1% /boot/efi
>Base System Installation Checklist:
>[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it
>Initial boot:           [O]
>Detect network card:    [O]
>Configure network:      [O]
>Detect CD:              [O]
>Load installer modules: [O]
>Clock/timezone setup:   [O]
>User/password setup:    [O]
>Detect hard drives:     [O]
>Partition hard drives:  [E]
>Install base system:    [O]
>Install tasks:          [O]
>Install boot loader:    [E]
>Overall install:        [O]

>- The initial partitions in the "guided partition" of the disk made
>  just two linux partitions, the main one and the swap. With that
>  scheme I did not manage to boot the system. THen I made my own
>  partitions, using ~36 MB for an EFI partition, plus the main
>  partition (where / is mounted) and the swap.  That scheme worked
>  fine, except for...
>- The grub installed almost correctly. It enters to Debian
>  smoothly. But when I try to enter to Windows 8 it tells me:
>    Error: unknown command 'drivemap'
>    Error: invalid EFI file path
>  Right now I have to go through the startup menu of the Bios to
>  enter Windows 8. I haven't managed to solve this problem myself.

OK, *this* is a known issue that I've reported myself. See
http://bugs.debian.org/698914 for the bug report, and information on
how to work around it.

>The question of the guided partition must be solved for the UEFI
>systems (I believe this should be easy), or at least a note should be
>put somewhere telling how to make your own manual partition.

ACK - I expect the code to already work...

>- Finally, the graphics did not work correctly until I installed the
>  packages related to the (non-free) driver of fglrx (for AMD/ATU
>  Radeon HD series). Before that it displayed some graphics but
>  gnome3 was not able to start.

OK, that's an unrelated issue..

Steve McIntyre, Cambridge, UK.                                steve@einval.com
"I've only once written 'SQL is my bitch' in a comment. But that code 
 is in use on a military site..." -- Simon Booth

Reply to: