[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Couldn't boot after installing 6.0.7-amd64 - GRUB problem

Hi there Debian community

I want to report a bug which took me quite a while to solve it.

I installed the version mentioned above on a HDD which had some Win-Data on a partition, but no win-OS (it might have been set "active").
The installation itself was no problem, but after booting from HDD there was no bootable OS available.
I tried to fix GRUB with the "Super Grub Disk" with not so great success.
After reinstalling GRUB with Knoppix, the GRUB-prompt was there on start-up.
I tried:
root (hd0,4)
kernel /vmlinuz root=/dev/sda5
initrd /initrd 

what then allowed me to boot from the debian.
Then I had first to:
apt-get update
and then install grub again.

Because first the grub version was 0.98 (which did not run for me) and now with grub v2 everything is fine,
I think there might be a bug in 6.0.7-amd64, messing up the grub versions?!

To be honest, the problem could also have been the win-partition and it's mbr-table, I just don't know.
Just wanted to tell you, so other people can be prevented from this...


Reply to: