[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: d-i for wheezy on a Dreamplug, docs/recommended practice?

Hi Ian,

ijc@hellion.org.uk said:
> > Who can I contact about getting these steps into the wheezy installation
> > guide in some prominent place?
> As has been pointed out already a bug against the"installation-guide"
> package would be goods. Martin (who maintains some useful webpages at
> http://www.cyrius.com/debian/kirkwood) might also be interested in some
> content?

Unfortunately I still haven't got to a working installation :-(

Now that #703889 has been fixed, I just tried again with today's d-i daily
build. I can now get through the entire installation process, however the
installer claims that "No installable kernel was found in the package
repositories for this platform".

I went and installed the relevant bits manually from a shell inside d-i:

    $ chroot /target
    $ mount /proc
    $ mount /dev/pts
    $ apt-get install linux-image-3.2.0-4-kirkwood

This all seems to work, flash-kernel creates uImage, uInitrd, dtb in /boot
as expected.

I then told the installer to clean up and reboot, and tried booting the
newly installed kernel manually:

    Marvell>>usb start
    Marvell>>setenv bootargs console=ttyS0,115200 root=/dev/sda2
    Marvell>>ext2load usb 0:1 0x6400000 uImage
    Marvell>>ext2load usb 0:1 0x8000000 uInitrd
    Marvell>>ext2load usb 0:1 0xd000000 dtb
    Marvell>>bootm 0x6400000 0x8000000 0xd000000

This results in the kernel booting, but failing to mount the rootfs:

[   15.870007] No filesystem could mount root, tried: 
[   15.874922] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Inspecting the console messages shows that:

[    0.000000] Kernel command line: console=ttyS0,115200n8 earlyprintk

This is obviously wrong; the "root=/dev/sda2" I set in bootargs is not

Any ideas what might be wrong here? "help bootm" in U-boot seems to suggest
that I could pass extra args there, but I tried that and nothing changed.
My U-boot version is 2013.01.01.

> > Futher: What is a user w/o a JTAG device to do? How is he/she supposed to
> > run the installer?
> On the dreamplug the JTAG device is part of the serial console dongle,
> which since you are interacting with the serial console you appear to
> have?
> We could in principal provide a network-console version of the
> installer, as used on e.g. the QNAP devices
> http://www.cyrius.com/debian/kirkwood/qnap/ts-41x/install.html
> (obviously some of the specifics would differ with the dreamplug).
> However I'm not sure how worthwhile this is -- how many people get a
> dreamplug but don't shell out the little bit extra for the serial
> console?

I do have the JTAG; my question was aimed at people who have a DreamPlug
(or identical clone of some description) but no JTAG. As you say, this is a
small minority, plus the process of getting things installed via a network
console is IMO too fragile for "Joe user" anyway.

> > There is another method which is not mentioned anywhere(!!) which I use and
> > is 100% reliable, namely booting over UART using kwuartboot [2], loading
> > the new image also over UART using e.g. kermit and then flashing it. Would
> > it be worthwhile to document this somewhere? If so, where? Obviously this
> > only works for people with the JTAG unit/some other compatible UART level
> > converter.
> That is pretty neat, is it "just" driving the u-boot command line in an
> expect(1) like manner to start a kermit transfer or is it doing
> something clever?

As others have written, what this does is boot the SoC directly using the
UART port (IIRC using Xmodem, it's been a while since I looked at the SoC
docs). So you can also use it to restore a board with a bricked U-boot.

When I first got my DreamPlug I spent the best part of a week trying to get
OpenOCD to work and did not get anywhere. If you read e.g. the NewIT forums
you'll see that many other people have the same problem. So this is the
best option for a 100% reliable solution.


Reply to: