[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#664128: debian-installer: please default to grub-ieee1275 on powerpc instead of yaboot

On Tue, Oct 23, 2012 at 01:06:06PM -0400, Milan Kupcevic wrote:
> IBM Firmware does support filesystems, just not the same filesystems as
> Macs and Pegasos. IBM Firmware likes FAT and iso9660, Mac wants HFS,
> while Pegasos works with ext2, AFFS, and iso9660.
> If you put a bootloader on FAT filesystem you could put other meta
> information in /ppc/bootinfo.txt file so that IBM Firmware and other IBM
> boot management tools can get full textual description and optionally an
> icon of the bootable OS. It would make it possible to dual boot Linux
> (GRUB) and AIX while choosing which one you want to boot using standard
> IBM tools (ie Multiboot menu). We will see if we want to go this way or
> we want to keep resetting firmware variables using '/sbin/nvsetenv' on
> Linux and 'bootlist' on AIX when we want to reboot into the other OS.

I have never got it to work with a fat filesystem.  I have tried on a
p710 and a p520.  Maybe it worked on older ones.

> Yaboot installer installs yaboot on IBM Power machines exactly the same way.
> This will not make life harder nor easier for IBM users. Grub
> installation was not offered on IBM Power machines by d-i until now, and
> will not be offered after this particular change.

Well it looks like it will if you happen to create the /boot/grub
partition, except it won't work that way.  So the error message will
tell you to do something that won't work.

> Thank you for providing information about your experience with grub on
> IBM Power machines. After wheezy release we will go forward with
> transition from yaboot to grub. Your experience will be valuable for
> further discussion about d-i issues on IBM Power machines.

I will certainly try to help test it at that time.

The way I am using it is what grub-install expects on IBM powerpc at
this time.

I would love to see a working example where you use FAT on an IBM powerpc,
because I haven't found any reference to it in any of the documentation
or anywhere else, and it has never worked when I tried it.  The
openfirmware syntax where you specify a file on a filesystem simply
never worked on either machine I have here.  Seems to work fine on
Macs though.

I will look up the bootinfo.txt though.  Maybe that will provide some
hints.  Could make grub simpler to work with.

Len Sorensen

Reply to: