Bug#676001: Processed: reassign 676001 to busybox
On 08.06.2012 15:22, maximilian attems wrote:
> On Fri, Jun 08, 2012 at 03:10:42PM +0400, Michael Tokarev wrote:
>> On 08.06.2012 14:52, maximilian attems wrote:
>>> dude care to have a bit of patience before reassigning back,
>>> that be really nice.
>> I gave a few days, maybe it was too few, I dunno.
>>> On Tue, Jun 05, 2012 at 08:45:59AM +0400, Michael Tokarev wrote:
>>>> I disagree it is a busybox problem, and don't think it is a
>>>> switch_root business (be it from busybox or from util-linux).
>>> switch_root in util-linux does it.
>> Yes, but it is still none of its business.
> that is your personal opinon and shown to be wrong. (:
>>> If you name a command switch-root and not run-init, you'd have
>>> to take care to emmulate what the original command does.
>>> In this case it is util-linux is clearly predating busybox and thus
>>> busybox is buggy not fully implementing the command.
>> Almost no of busybox commands implements fully the corresponding
>> "big brother" behavour.
> well in the cases where it is needed and as busybox doesn't do it is a
Switch_root utility in util-linux appeared _after_ the same
utility appeared in busybox. In util-linux it was implemented
in 2009, http://git.kernel.org/?p=utils/util-linux/util-linux.git;a=commit;h=711ea7307d54caa74aa89fc7e8614236e3721f1c
This command there were taken from dracut apparently.
In there, it has been written in 2002 (I guess), has been
called "switchroot" (no underscore), and it does _umounting_
of /dev, /proc, /sys, as can be seen at
In busybox it has been implemented as switch_root in 2005, in this commit:
which, obviously, pre-dates the same command in util-linux.
There in busybox, it is named switch_root right from the
beginning, and were made after run-init behavour (instead
of the switchroot from dracut).
So we can conclude these implementations (in util-linux
and busybox) are independent and not follows or modelled
from one another.
In dractu, were it umounted /dev /proc /sys instead of
moving these, I guess it was modelled after nash which
was a bad example of shell to use in initrd, it didn't
have most standard shell constructs so it weren't easy
to program in it. But I can only guess.
> run-init doesn't move mount things, you could rename switch_root
> to run-init, then it would be correct.
> You confuse things, switch_root is the new command name by util-linux
> and it does a certain number of things. It doesn't matter, if
> you personally agree with them or not.
> Ah and please stop evading into the init script.