[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#669605: debootstrap can't install base-files and base-passwd

Package: debootstrap
Version: 1.0.39
Severity: critical
Justification: breaks unrelated software

I'm trying to create a debian system and after I call:

debootstrap --verbose --arch=i386 --include=quagga,linux-
image-686-pae,syslinux,vim,gawk wheezy /media/jffs2 ftp://ftp.lug.ro/debian

I'm getting this error:

I: Extracting liblzma5...
I: Extracting xz-utils...
I: Extracting zlib1g...
I: Installing core packages...
W: Failure trying to run: chroot /media/jffs2 dpkg --force-depends --install
/var/cache/apt/archives/base-files_6.7_i386.deb /var/cache/apt/archives/base-

I've tried to run the command and the output is:

root@MyDebian:/media# chroot /media/jffs2 dpkg --force-depends --install
/var/cache/apt/archives/base-files_6.7_i386.deb /var/cache/apt/archives/base-
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 48 package 'dpkg':
 missing description
dpkg: warning: parsing file '/var/lib/dpkg/status' near line 48 package 'dpkg':
 missing architecture
dpkg: regarding .../base-files_6.7_i386.deb containing base-files, pre-
dependency problem:
 base-files pre-depends on awk
  awk is not installed.
dpkg: warning: ignoring pre-dependency problem!
(Reading database ... 109 files and directories currently installed.)
Preparing to replace base-files 6.7 (using .../base-files_6.7_i386.deb) ...
Unpacking replacement base-files ...
Preparing to replace base-passwd 3.5.24 (using .../base-passwd_3.5.24_i386.deb)
Unpacking replacement base-passwd ...
dpkg: base-passwd: dependency problems, but configuring anyway as you
 base-passwd depends on libc6 (>= 2.1); however:
  Package libc6 is not installed.
Setting up base-passwd (3.5.24) ...
dpkg: base-files: dependency problems, but configuring anyway as you requested:
 base-files depends on awk; however:
  Package awk is not installed.
Setting up base-files (6.7) ...
cp: preserving permissions for `/etc/profile': Permission denied
dpkg: error processing base-files (--install):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:

-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: i386 (i686)

Kernel: Linux 3.2.0-2-686-pae (SMP w/2 CPU cores)
Locale: LANG=en_US.ISO-8859-1, LC_CTYPE=en_US.ISO-8859-1 (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/dash

Versions of packages debootstrap depends on:
ii  wget  1.13.4-3

Versions of packages debootstrap recommends:
ii  debian-archive-keyring  2010.08.28
ii  gnupg                   1.4.12-4

debootstrap suggests no packages.

-- no debconf information

Reply to: