[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#655579: debian-installer: Unable to perform an installation : USB-input devices unusable

Package: debian-installer
Severity: important
Tags: d-i

Dear Debian Team,

I have been facing this major issue since the very first official release of Squeeze,
so I will try being as consistent and to the point in describing it, as I can.

Since the first release of Squeeze 6.0, the only possible way for me of installing Debian 
has always been the official AMD64-DVD. It is still the only possible media which recognizes
a plugged keyboard and allows me to use my Apple Aluminium keyboard - and go through the installation process (mice do not work).
No installation from any other distribution works (netboot, testing-netboot etc),
due to the fact that the keyboard and mouse are unusable there - as soon as I choose "graphical expert install"
and it has loaded, I can't even get past the very first screen. I have been trying with PS2-devices, other USB-keyboards and mice,
all in vain. I then decided to jump to "Wheezy", where I did hope this might had been fixed,
but to my surprise - I had to give up with a Wheezy netboot installation as well, because USB-devices were not working again.
All input devices do work normally during POST, before entering the installer and when Debian is installed and running.

Here the details :
- "Wheezy" AMD64 Netboot-CD (20120102-04:49)
- Asus P5Q3 Deluxe WiFi-Ap @n
- Intel Core 2 Quad Q9550
- Nvidia GTX285
- Apple Aluminium keyboard with numeric touchpad (Model No.A1243, EMC No.2171)
- played around with USB-options in the BIOS - no go
- plugged/replugged the keyboard, a generic usb-mouse, a PS2-KB & mouse - no go

I went through the "Help" menu of the netboot-cd, read the options, tried with most (acpi/apic etc).
I tried collecting as much information as possible, but the messages are briefly the ones showed below,
these come up when I type in "install expertgui" at the boot-prompt (from the help-menu) :

1. From the main terminal :
(process : 4170) : INFO :kbd-mode : setting console mode to Unicode (UTF-8)
The screen is flashing and the above line is repeating at every second or two, with an ever-increasing process number.

2. When i switched to another terminal :
main-menu[1526] :DEBUG: resolver (libc-udeb) : package doesn't exist (ignored)
main-menu [1526]:INFO: Menu item 'localechooser' selected
debconf : Setting debconf/language to en
kernel : [18.686451] debconf [1520] : segfault at 2000000036 ip 00007f89c8d29 sp 00007fff0e96bb50 error 4 in libc.so.6[7f89c6985000 + ff000]
init : process '/sbin/reopen-console /sbin/debian-installer' (pid 1509) exited. Scheduling for restart
init: starting pid 1614, tty '': '/sbin/reopen-console /sbin/debian-installer'

This is repeating as well, with init constantly re-spawning the process and the process numbers increasing with time.

Please, let me know if there is any other way I could gather a more in-detail output, log it
and send it if necessary ( I was trying to figure out how to do it myself, but... :) )

Thank you very much in advance, 

Best Regards

Radostin Dimitrov


-- System Information:
Debian Release: wheezy/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 3.1.0-1-amd64 (SMP w/4 CPU cores)
Locale: LANG=en_US.utf8, LC_CTYPE=en_US.utf8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Reply to: