[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#226758: marked as done (grub-installer: detecting wrong root partition)

Your message dated Wed, 12 Jan 2011 00:01:17 +0000
with message-id <1294790477.3497.134.camel@eeepc.Belkin>
and subject line 
has caused the Debian Bug report #226758,
regarding grub-installer: detecting wrong root partition
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

226758: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=226758
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Obtained from http://people.debian.org/~manty/testing/netinst/
on 06-Jan-2004

uname -a: Linux polar 2.4.22-1-386 #9 Sat Oct 4 14:30:39 EST 2003 i686
GNU/LinuxDate: Wed Jan  7 05:23:49 EST 2004
I booted of the daily snapshot netinst CD. Packages came from a combo of
the CD and the network.
Machine: Custom workstation
Processor: 2.4 Ghz Pentium 4 Xeon
Memory: 1GB
Root Device: SCSI /dev/sda
Root Size/partition table:
/dev/hda1       256 MB  /boot
/dev/sda2       22 GB   /
/dev/sda3       1 GB    swap
Output of lspci:
00:00.0 Host bridge: Intel Corp. E7505 Memory Controller Hub (rev 03)
00:00.1 Class ff00: Intel Corp. E7000 Series RAS Controller (rev 03)
00:01.0 PCI bridge: Intel Corp. E7000 Series Processor to AGP Controller
(rev 03)
00:02.0 PCI bridge: Intel Corp. E7000 Series Hub Interface B PCI-to-PCI
Bridge (rev 03)
00:1d.0 USB Controller: Intel Corp. 82801DB USB (Hub #1) (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801DB USB (Hub #2) (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801DB USB (Hub #3) (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801DB USB2 (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB PCI Bridge (rev 82)
00:1f.0 ISA bridge: Intel Corp. 82801DB LPC Interface Controller (rev
00:1f.1 IDE interface: Intel Corp. 82801DB Ultra ATA Storage Controller
(rev 02)00:1f.3 SMBus: Intel Corp. 82801DB/DBM SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV15 [GeForce2
GTS/Pro] (rev a3)
02:1c.0 PIC: Intel Corp. 82870P2 P64H2 I/OxAPIC (rev 03)
02:1d.0 PCI bridge: Intel Corp. 82870P2 P64H2 Hub PCI Bridge (rev 03)
02:1e.0 PIC: Intel Corp. 82870P2 P64H2 I/OxAPIC (rev 03)
02:1f.0 PCI bridge: Intel Corp. 82870P2 P64H2 Hub PCI Bridge (rev 03)
03:05.0 SCSI storage controller: Adaptec AIC-7902 U320 (rev 03)
03:05.1 SCSI storage controller: Adaptec AIC-7902 U320 (rev 03)
05:01.0 Multimedia audio controller: Cirrus Logic CS 4614/22/24
[CrystalClear SoundFusion Audio Accelerator] (rev 01)
05:03.0 Ethernet controller: Intel Corp. 82540EM Gigabit Ethernet
Controller (rev 02)
Base System Installation Checklist:
Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E] see below
Reboot:                 [O]
I typically put my boot partition and my boot loader on an IDE disk
because there is a small delay when booting off of SCSI. I installed
grub to /dev/hda which worked fine but its configuration was not
correct. Here's the relevant section of its configuration:
title           Debian GNU/Linux, kernel 2.4.22-1-386
root            (hd1,1)
kernel          /vmlinuz-2.4.22-1-386 root=/dev/sda2 ro
initrd          /initrd.img-2.4.22-1-386
The problem is that it's looking for the kernel /vmlinuz-2.4.22-1-386 on
the root of (hd1,1), but (hd1,1) is the wrong partition. (hd1,1) is
/dev/sda2 which is my / partition. The (hd1,1) above should be (hd0,0)
which is /dev/hda1 which is my /boot partition.
Other than that the install went well.

Avery Fay

--- End Message ---
--- Begin Message ---

Thanks for your report.
Closing as it's an installation report from debian installer version
which isn't supported anymore.
Feel free to test and report any issues against the current debian
installer release (Squeeze RC1) which supports more hardware and also
it's improved.


Melhores cumprimentos/Best regards,

Miguel Figueiredo

--- End Message ---

Reply to: