[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#599200: base-installer: Install amd64 kernel on i686 kvm guest - and fail to boot

severity 599200 important

[Ben Hutchings]
> Please specify exactly which versions of kvm/qemu-kvm and the kernel you
> are running in the host, and whether you are using the kvm modules from
> the linux-image-2.6.26-2-686 or built from kvm-source.

I finally found time to have a look, and it seem that I was wrong.
The machine do not run the Lenny kvm and kernel.  It uses older
packages from backports:

  kvm 85+dfsg-4~bpo50+1
  linux-image-2.6.30-bpo.1-686 2.6.30-6~bpo50+1

I am not sure why the machine isn't using the Lenny packages, but as
Ben find that the problem do not affect the normal Lenny packages and
I am unable to confirm this or not, I reduce the severity to important
as I assume it only affect those of us with backported kernels, and
not all Lenny users.

I've implemented the workaround using cpu=pentium3, so I no longer am
affected by this problem.

Happy hacking,
Petter Reinholdtsen

Reply to: