[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#599200: base-installer: Install amd64 kernel on i686 kvm guest - and fail to boot

[Lennart Sorensen]
> Well try starting the kvm with '-cpu qemu32'.  That should provide
> the feature flags of a nice 32bit x86.

I tried  this by adding

  <cpu match='exact'>

to the libvirtm XML file for the virtual machine, which caused '-cpu
qemu32' to be part of the kvm command line.  There is no GUI to add
this in virt-manager, as far as I can see, so this will be out of
reach for most users.  No idea if this give hardware virtualization or
software virtualization.  The qemu part of the model name make me
suspect the latter.

Anyway, booting the virtual machine and looking at the CPU flags in
cpuinfo, I can confirm that the lm flag is gone.  I also tried with
model=pentium3, and this too did not have the lm flag.  This solve my
imediate problem of testing the Debian Edu DVD, but do not address the
problem for the unexpecting user of kvm.

Happy hacking,
Petter Reinholdtsen

Reply to: