[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#599203: os-prober: Causes Data Corruption on a SAN setup; Mounts SAN volumes that are already mounted on a different host.

Quoting Christian PERRIER (bubulle@debian.org):
> Quoting Aleksandr Levchuk (alevchuk@cs.ucr.edu):
> > Package: os-prober
> > Version: 1.39
> > Severity: important
> > 
> > 
> > An upgrade (os-prober 1.35 -> 1.39) corrupted 3.3 TB of data on our SAN.
> Sigh. From what I've witnessed over the years, os-prober has always
> been designed as a component of Debian Installer, used to properly
> setup boot loaders' menus at install time.
> Apparently, recent evolutions turned it to be installed on running
> systems *because* grub recommends it.

well, Colin Watson is about to say that he disagrees with that

Let's have him elaborate...

Attachment: signature.asc
Description: Digital signature

Reply to: