[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#260110: marked as done (Install Report: expert26 on Toshiba Satellite Pro M15-S405)

Your message dated Wed, 08 Sep 2010 03:58:41 +0000
with message-id <E1OtBo1-00066r-0p@ravel.debian.org>
and subject line Closing old installation report #260110
has caused the Debian Bug report #260110,
regarding Install Report: expert26 on Toshiba Satellite Pro M15-S405
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

260110: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=260110
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: 20040716 sarge netinst (nightly)
uname -a: Linux cpp 2.6.6-1-386 #1 Wed May 12 13:19:06 EST 2004 i686 GNU/Linux
Date: 17 July 2004, ~15:00+0000
Method: Burned sarge-i386-netinst.iso to a CDR/W and booted from it; booted with "expert26 acpi=on"; chose to install SID

Machine: Toshiba Satellite Pro M15-S405
Processor: Pentium M 1400MHz
Memory: 512 MB
Root Device: ide: /dev/hda3
Root Size/partition table:
/dev/hda1 : start=       63, size=  8401932,  Id= 7,  bootable
/dev/hda2 : start= 74814705, size=  3325455,  Id= 5
/dev/hda3 : start=  8401995, size= 66412710,  Id=83
/dev/hda4 : start=        0, size=        0,  Id= 0
/dev/hda5 : start= 74814768, size=  1959867,  Id= b
/dev/hda6 : start= 76774698, size=  1365462,  Id=82

hda1 => WinXP (NTFS)
hda3 => Debian (XFS)
hda5 => transfer partition (FAT32)
hda6 => swap (Linux swap v2)

Output of lspci:
0000:00:00.0 Host bridge: Intel Corp. 82855PM Processor to I/O Controller (rev 03) 0000:00:01.0 PCI bridge: Intel Corp. 82855PM Processor to AGP Controller (rev 03)
0000:00:1d.0 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #1 (rev 03)
0000:00:1d.1 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #2 (rev 03)
0000:00:1d.2 USB Controller: Intel Corp. 82801DB (ICH4) USB UHCI #3 (rev 03)
0000:00:1d.7 USB Controller: Intel Corp. 82801DB (ICH4) USB2 EHCI Controller (rev 03)
0000:00:1e.0 PCI bridge: Intel Corp. 82801BAM/CAM PCI Bridge (rev 83)
0000:00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 03) 0000:00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage Controller (rev 03) 0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB (ICH4) AC'97 Audio Controller (rev 03) 0000:00:1f.6 Modem: Intel Corp. 82801DB (ICH4) AC'97 Modem Controller (rev 03) 0000:01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 420 Go] (rev a3) 0000:02:07.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link) 0000:02:08.0 Ethernet controller: Intel Corp. 82801BD PRO/100 VE (MOB) Ethernet Controller (rev 83) 0000:02:0a.0 Network controller: Intel Corp. PRO/Wireless LAN 2100 3B Mini PCI Adapter (rev 04) 0000:02:0b.0 CardBus bridge: Toshiba America Info Systems ToPIC95 PCI to Cardbus Bridge with ZV Support (rev 32) 0000:02:0b.1 CardBus bridge: Toshiba America Info Systems ToPIC95 PCI to Cardbus Bridge with ZV Support (rev 32) 0000:02:0d.0 System peripheral: Toshiba America Info Systems SD TypA Controller (rev 03)

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [ ]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Most everything worked well. I had previously partitioned the disk from a rescue CD (which I had used to resize the default NTFS partition). When I chose to use XFS for my root partition, the installer warned me about some issue with GRUB. Later, when I chose to install GRUB, it just sat and consumed CPU (I let it sit for >3 hrs; nothing happened). I killed it (signal 15) and the installer reported that no warnings had been output, and that consequently everything had completed successfully. Perhaps it should check the exit code? I chroot'd to /target and installed grub manually from the pre-existing menu.lst (using the grub command line, not grub-install), and that worked fine.

I was disappointed that the installer detected that I needed the ipw2100 module (it's a Centrino laptop), but the module was apparently unavailable. I assume this is because of the firmware dependency, but if so, this should be explained. Potentially, users should be able to provide the firmware on a floppy (for small firmwares; I don't remember exactly what size the 2100 firmware is) or on a mass-storage device.

Alternately, expert users (expert or expert26) should be able to download the firmware and untar it somewhere for the installer to use. This would require some non-firmware-dependent internet connection at the beginning, but would allow the majority of the installation to complete over the wireless interface

Instead of (or in addition to) using the ipw2100 driver, ndiswrapper may be a good idea: it supports a broader range of chipsets (again, pending firmware) for which specific drivers may or may not be available (I haven't really looked).

I selected the IPv6 box in the "Cool Stuff Support" section, but apparently no v6 support was loaded (eth0 lacked a link-local address). Also, I do have a v6 router, so if v6 support was loaded, it should have sent a router sol. or few and picked the route up immediately. On initial boot, however, v6 support was loaded and worked properly.

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: