[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#251758: marked as done (Installer: reboot fails, missing modules)

Your message dated Wed, 08 Sep 2010 03:58:38 +0000
with message-id <E1OtBny-00062Y-Su@ravel.debian.org>
and subject line Closing old installation report #251758
has caused the Debian Bug report #251758,
regarding Installer: reboot fails, missing modules
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

251758: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=251758
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: <Daily build installer for i386, 2004-05-28 network install 106MByte expert26>
Final uname -a: <Linux space01 2.6.5-1-686-smp #2 SMP Fri Apr 30 20:35:03 EST 2004 i686 GNU/Linux>
Date: <May 30 2004>
Method: <network install, from uk.debian.org direct>

Machine: <Shuttle Spacewalker HOT-649A>
Processor: Dual Pentium II 450
Memory: 768MB
Root Device: <IDE /dev/hda1>
Root Size/partition table: <
 /dev/hda1 approx 10 percent of 25GB used          ext3  /
 /dev/hda2 1GB                                           swap
 /dev/hdc1 20GB                                    ext3  /home
 /dev/hdc2 100GB available for multimedia editing  ext2  /max01
 /dev/sda1 70GB  available for multimedia editing  ext2  /cheetah01 >

Output of lspci: (taken from a previous attempt)

0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:08.0 SCSI storage controller: Adaptec AHA-2940U2/U2W / 7890/7891
0000:00:09.0 Ethernet controller: Intel Corp. 82557/8/9 [Ethernet Pro 100] (rev 05)
0000:00:0a.0 FireWire (IEEE 1394): Texas Instruments TSB12LV23 IEEE-1394 Controller
0000:00:0b.0 Multimedia controller: Sigma Designs, Inc. REALmagic Hollywood Plus DVD Decoder (rev 02)
0000:00:0c.0 Multimedia controller: Philips Semiconductors SAA7146 (rev 01)
0000:01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA 2164W [Millennium II] AGP

Base System Installation Checklist:

Initial boot worked:    [O ]
Configure network HW:   [O ]
Config network:         [O ]
Detect CD:              [O ]
Load installer modules: [O ]
Detect hard drives:     [O ]
Partition hard drives:  [O ]
Create file systems:    [O ]
Mount partitions:       [O ]
Install base system:    [O ]
Install boot loader:    [E ] When trying to use only lilo
Reboot:                 [E ] Missing modules
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


   Please note that I am by no means an expert!

   Installer daily test 2004.05.28 106MByte net install, expert26

Initial install reported missing modules ide-scsi, ide-mod, ide-probe-mod,
ide-detect, ide-floppy

   I did not manage to get it to use a local apt-proxy server (tried various
configurations). Attempts to ping the local apt-proxy server by name fail,
unknown host, attempts to ping the local apt-proxy server by IP address
succeed, the local apt-proxy server is running Woody 3.0r2 with BIND9, and
is configured to be the first DNS nameserver, so was probably used for the
initial load. Another box running sarge from an earlier install is now able
to access the apt-proxy, and use jigdo to download the full installation set
via the apt-proxy, so I know it should be possible, (and I should be able to
build the next test set using mainly the contents of apt-proxy).

   Otherwise all appeared to go well until the first reboot.

   First re-boot stopped because neither aic7xxx nor eepro100 were loaded,
the SCSI sda1 was not found, and e2fsck stopped the boot sequence.
   I did a modprobe for both and they appeared to be available but not
installed. I then edited /etc/modules to add


at the bottom of the list and did a shutdown -r (on a subsequent attempt I
used ctrl-d to contiue)

   There was a message about hub 1-0-1.0 ports 1 & 2 overcurrent that
flashed by too fast for me to get details, and it then stalled with the
following shown on screen (copied by hand) and I was not able to view any
other screens.

EFLAGS: 00010296   (2.6.5-1-386)
EIP is at kobject_add+0x67/0xb0
eax: c02b86a0   ebx: f0b049bc   ecx: f0be7a18   edx: f0b049d8
esi: c02b86a8   edi: f0b049a4   ebp: 00000000   esp: ef3adf38
ds: 007b   es: 007b   ss: 0068
Process modprobe (pid: 907, threadinfo=ef3ac000 task=eec57700)
Stack: f0b049bc ffffffea f0b049a4 c018c1d5 f0b049bc f0b049bc f0b049bc c02b8640
       c01d17e7 f0b049bc f0b049bc f0b01034 f0b04980 00000000 f0b04a18 c0287818
       c01d1a3f f0b049a4 f0ae5754 f0adf000 00000000 c02773f8 c0193cf8 f0b049a4
Call Trace:
 [<c018c1d5>] kobject_register+0x1b/0x3d
 [<c01d17e7>] bus_add_driver+0x30/0x61
 [<c01d1a3f>] driver_register+0x2d/0x31
 [<c0193c1f>] pci_register_driver+0x4e/0x6b
 [<f084c00a>] ohci1394_init+0xa/0x12 [ohci1394]
 [<c012e5d8>] sys_init_module+0xe3/0x1d1
 [<c0109253>] syscall_call+0x7/0xb

Code: 89 11 89 4a 04 8b 43 28 8b 00 83 c0 48 e8 67 11 00 00 89 73
 /etc/hotplug/pci.agent: line 156:   907 Segmentation fault      $MODPROBE $MODULE >/dev/null 2>&1
     ohci1394: can't be loaded
missing kernel or user mode driver ohci1394
saa7146: register extension 'budjet dvb'.

(flashing cursor) Hung, would not accept keyboard entry.


   I then tried to repeat the installation but use lilo instead of grub. At
no time did I select grub, only lilo. All went as above until the first
reboot, but then there was an error message not from lilo but from grub, and
everything stopped.


   I then tried

   Installer daily test 2004.05.28 33MB Businesscard expert26

baseconfig-udeb loaded

Unable to get it to use a local apt-proxy server (tried various
configurations) as above. This time the local apt-proxy server was
configured as the only nameserver. (Note: Next time I will try adding "deb "
at the beginning of the apt-proxy http address to see if that works.)

source uk.debian.org selected, with kernel-image-2.6.5-1-686-smp

   This time the reboot hung again when e2fsck could not find sda1 and I
then edited /etc/modules to add 3 modules instead of just the 2 above,


Restarting went straight through to the menu headed by the welcome page.

   There was no option to include any (?suggested selection of?) additional
modules which should be loaded immediately for the initial reboot, it
appears that missing modules on the initial reboot was the problem, even
causing the overcurrent message above. This could persuade a total newbie to
give up and not to bother.

   I prefer to set the adduser --uid so that the same user has the same uid
on all machines on the network. The businesscard installer did not offer the
choice of UID for the first user, but did not force me to create an ordinary
user at that time, so I could change to a different screen and adduser --uid

   The installation is not yet complete, but appears to be progressing OK. I
intend to try reboots as now configured, also with the eepro100 removed from
the list in /etc/modules to check whether the card will still work and is
still assigned as eth0, not eth1, as at one point the firewire card appeared
to be eth0 (it is only there to connect to a camera, not my network).

Hope you find this useful. Thanks for all the hard work.

Chris Bell

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: