[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#274628: marked as done (OldWorld PowerPC Mac using BootX and 2.4 kernel from pre-rc2 businesscard CD - mostly successful - a few surprises.)

Your message dated Wed, 08 Sep 2010 03:57:41 +0000
with message-id <E1OtBn3-00046h-I4@ravel.debian.org>
and subject line Closing old installation report #274628
has caused the Debian Bug report #274628,
regarding OldWorld PowerPC Mac using BootX and 2.4 kernel from pre-rc2 businesscard CD - mostly successful - a few surprises.
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

274628: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=274628
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports


Debian-installer-version: <Fill in date and from where you got the image>

	pre-rc2 businesscard CD
	Index of /pub/cdimage-testing/daily/powerpc/pre-rc2
	 Name                           Last modified       Size  Description
	 Parent Directory               02-Oct-2004 00:08      -
	 MD5SUMS                        01-Oct-2004 00:21     1k
>>>	 sarge-powerpc-businesscard.iso 01-Oct-2004 00:12   112M
	 sarge-powerpc-netinst.iso      01-Oct-2004 00:20   259M
	Apache/1.3.31 Server at cdimage.debian.org Port 80

uname -a: <The result of running uname -a on a shell prompt>

Linux debian 2.4.27-powerpc #1 ven sep 3 09:34:51 CEST 2004 ppc GNU/Linux

Date: <Date and time of the install>

	Sun Oct  3 02:22:32 EDT 2004

Method: How did you install?  What did you boot off?  If network
  install, from where?  Proxied?

PowerPC Oldworld Macintosh with BootX bootloader using 2.4.27 kernel and initrd
	network components from ftp.us.debian.org "testing" repository
	not proxied

Machine: <Description of machine (eg, IBM Thinkpad R32)>

	PowerPC Oldworld Macintosh beige G3 minitower


	processor       : 0
	cpu             : 740/750
	temperature     : 36-41 C (uncalibrated)
	clock           : 300MHz
	revision        : 2.2 (pvr 0008 0202)
	bogomips        : 601.29
	machine         : Power Macintosh
	motherboard     : AAPL,Gossamer MacRISC
	detected as     : 48 (PowerMac G3 (Gossamer))
	pmac flags      : 00000000
	L2 cache        : 1024K unified pipelined-syncro-burst
	memory          : 384MB
	pmac-generation : OldWorld


	384 MB

Root Device: <IDE?  SCSI?  Name of device?>

	IDE controller "Ultra ATA 133/100 pro" from SIIG, Inc.
	AEC6880R: chipset revision 6
	hdc: Maxtor 6Y160P0, ATA DISK drive

Root Size/partition table:  Feel free to paste the full partition
  table, with notes on which partitions are mounted where.

	debian:~# mac-fdisk -l /dev/hdc
# type name length base ( size ) system /dev/hdc1 Apple_partition_map Apple 63 @ 1 ( 31.5k) Partition map /dev/hdc2 Apple_Driver43 Macintosh 54 @ 64 ( 27.0k) Driver 4.3 /dev/hdc3 Apple_Driver43 Macintosh 74 @ 118 ( 37.0k) Driver 4.3 /dev/hdc4 Apple_Driver_IOKit Macintosh 512 @ 192 (256.0k) Unknown /dev/hdc5 Apple_Patches Patch Partition 512 @ 704 (256.0k) Unknown /dev/hdc6 Apple_HFS untitled 2097152 @ 1216 ( 1.0G) HFS /dev/hdc7 Apple_UNIX_SVR2 root 19531251 @ 2098368 ( 9.3G) Linux native /dev/hdc8 Apple_UNIX_SVR2 swap 1953126 @ 21629619 (953.7M) Linux swap /dev/hdc9 Apple_UNIX_SVR2 root 19531251 @ 23582745 ( 9.3G) Linux native /dev/hdc10 Apple_UNIX_SVR2 Root-10 5859376 @ 43113996 ( 2.8G) Linux native /dev/hdc11 Apple_UNIX_SVR2 root-11 5859376 @ 48973372 ( 2.8G) Linux native /dev/hdc12 Apple_UNIX_SVR2 root-12 5859376 @ 54832748 ( 2.8G) Linux native /dev/hdc13 Apple_Free Extra 259480932 @ 60692124 (123.7G) Free space
	Block size=512, Number of Blocks=320173056
	DeviceType=0x0, DeviceId=0x0
	1: @ 64 for 23, type=0x1
	2: @ 118 for 36, type=0xffff
	debian:~# mount
	/dev/hdc12 on / type ext3 (rw,errors=remount-ro)
	proc on /proc type proc (rw)
	devpts on /dev/pts type devpts (rw,gid=5,mode=620)
	tmpfs on /dev/shm type tmpfs (rw)
	usbfs on /proc/bus/usb type usbfs (rw)
	Root on hdc12
	Swap on hdc8
	Other partitions are unused in this installation.

Output of lspci and lspci -n:

	debian:~# lspci
	0000:00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
0000:00:0d.0 Ethernet controller: D-Link System Inc RTL8139 Ethernet (rev 10) 0000:00:0e.0 SCSI storage controller: Artop Electronic Corp ATP865 (rev 06) 0000:00:0f.0 PCI bridge: Hint Corp HB6 Universal PCI-PCI bridge (non-transparent mode) (rev 13)
	0000:00:10.0 ff00: Apple Computer Inc. Heathrow Mac I/O (rev 01)
0000:00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage I/II 215GT [Mach64 GT] (rev 9a)
	0000:01:08.0 USB Controller: NEC Corporation USB (rev 41)
	0000:01:08.1 USB Controller: NEC Corporation USB (rev 41)
	0000:01:08.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
0000:01:0b.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394 Controller (Link)
	debian:~# lspci -n
	0000:00:00.0 0600: 1057:0002 (rev 40)
	0000:00:0d.0 0200: 1186:1300 (rev 10)
	0000:00:0e.0 0100: 1191:0009 (rev 06)
	0000:00:0f.0 0604: 3388:0021 (rev 13)
	0000:00:10.0 ff00: 106b:0010 (rev 01)
	0000:00:12.0 0300: 1002:4754 (rev 9a)
	0000:01:08.0 0c03: 1033:0035 (rev 41)
	0000:01:08.1 0c03: 1033:0035 (rev 41)
	0000:01:08.2 0c03: 1033:00e0 (rev 02)
	0000:01:0b.0 0c00: 104c:8020

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [o] Note 1
Configure network HW:   [o]
Config network:         [o]
Detect CD:              [o]
Load installer modules: [o]
Detect hard drives:     [o]
Partition hard drives:  [o]
Create file systems:    [o]
Mount partitions:       [o]
Install base system:    [o]
Install boot loader:    [ ] Note 2
Reboot:                 [o]
Post Reboot config:     [?] Note 2,3 & 4


  <Description of the install, in prose, and any thoughts, comments
  and ideas you had during the initial install.>

	All-in-all, a pretty easy install with no major problems.

	Note 1:
BootX has a default initrd size of 8192. This was not large enough. The first time I tried to boot, it failed trying to "access beyond the end of the device". from the sizes quoted in the error message, I assume that the "device" in question was the 8MB ramdisk. I manually changed the initrd size to 16384. Initial boot worked then.

	Note 2:
I'm using the BootX bootloader for this test. Even though I specifically skipped installing the "quik" bootloader in the part of the installation before the reboot, when we got to the the after-reboot part it again tried to install the quik bootloader. I had to answer "No" specifically.

	Note 3:
I asked it to install the "print server" task. Even though I had made ever effort to convince it that I was an English speaker in the US, it nevertheless wanted to default to "A4" paper in the printer task setup. I chose "letter", instead.
	Here's the relevant part of the environment:

	Note 4:
In the after-reboot configuration phase, it asked me about parameters for "setserial". I had never once mentioned previous to this that I wanted to do anything at all with serial ports, so this was a bit surprising. The question it asked probably could have defaulted to the suggested choice (save config once only) and spared me the puzzlement.

	Log files and a tarball of /proc/device-tree are available at

Install logs and other status info is available in /var/log/debian-installer/.
Once you have filled out this report, mail it to submit@bugs.debian.org.

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: