[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#273768: marked as done (parted issues (aboot))

Your message dated Wed, 08 Sep 2010 03:57:40 +0000
with message-id <E1OtBn2-000455-Pe@ravel.debian.org>
and subject line Closing old installation report #273768
has caused the Debian Bug report #273768,
regarding parted issues (aboot)
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

273768: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=273768
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: daily sep26 alpha
uname -a: Linux tull 2.4.27-1-generic #1 Sat Sep 4 01:15:04 CEST 2004 alpha unknown
Date: Mon Sep 27 20:53:16 EDT 2004
Method: netboot from tftp server
Machine: Alphastation 255
Processor: ~233MHz
Memory: 64M
Root Device: SCSI
Root Size/partition table: sdb(2G)=/ sda(1G)=aboot,/boot,swap,other
Output of lspci and lspci -n:

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O] *
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


* this ignores the problems dealt with separately in Bug#273437

First time through:

Booted, tried to change debconf priority but no menu option for it.
Went in to configure anna source
Downloaded and installed default module components
Now debconf priority available so selected low
Went in to configure anna source, selected "unstable"
Went back into install module components to get kernel modules
Shelled out and did some data backups of old drive using nc
Played around a bit with stuff, including loading "search for isos",
  which was able to recognize filesystems just fine.
Started parted.  Here is where the problems began.

Two drives in the machine.  sdb was old system drive, one partition
was second half of a failed raid1, probably disklabel partitioned.
sda had one small parition, not disklabel, done under i386 with ext2,
and the rest free space.  Filesystem detection failed, partitions
showed no filesystem type even the ext2 on sda.

Deleted partitions on sdb, created one large primary as /
Redefinined 32M ext2 partition on sda as /boot.
Added other partitions to sda.
During finish, got aboot warning.
Went back in to try to change 32M partition to aboot
Installer would no longer offer aboot as an option, even when
 creating a new partition with /boot already defined on that disk.
Backed out of installer and reentered.
 aboot option reappeared.  Went to finish, but at this point /boot
 was not a separate partition and was thus on sdb, so got a different
Went back into partitioner to get things right (/boot and aboot on
same disk).
Could not get aboot option again.
(my recollection gets a little fuzzier here)
Eventually got things looking right, but got warning about no disklabel
Started getting messages about VM killing process choice
Often by this point could not get ext2 option
Before I could get a shell open to check ps, all new processes were dying

Second run:

Escaped out after language selection.
This time instead of trying choose mirror, went directly to install components
  -- was presented with the choice of distro, despite not having done anything
     with debconf priority.  Chose unstable.
Install proceeded normally.
This time, partition filesystems were detected and showed in parted
Couldn't find any options to create disklabel, and no fdisk
Eventually figured out that deleting all partitions on sda would
 create disklabel if aboot added first as top partition -- a rather
 obfuscated and undocumented way to do things IMO
Completed partitioning successfuly
Install completed successfully

partman log attached, see Bug#273437 for hw-summary,
other logs available by request.

Upon reboot, minor note, read-edid had no installation candidate

Attachment: partman.bz2
Description: partman from second run

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: