[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#269147: marked as done (Package: installation-reports)

Your message dated Wed, 08 Sep 2010 03:57:36 +0000
with message-id <E1OtBmy-0003vR-Jz@ravel.debian.org>
and subject line Closing old installation report #269147
has caused the Debian Bug report #269147,
regarding Package: installation-reports
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

269147: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=269147
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: 17 August 2004, http://cdimage.debian.org/pub/cdimage-testing/sarge_d-i/powerpc/rc1/sarge-powerpc netinst.iso
uname -a: Linux oldworld 2.4.25-powerpc #1 mer avr 14 15:38:38 CEST 2004 ppc GNU/Linus
Date: Tues 24 August, 1500
Method: Used downloaded CD boot images from http://http.us.debian.org/debian/dists/testing/main/installer-powerpc/rc1/images/powerpc/cdrom/
Booted from OS9 on the mac and used BootX to load CD boot image. From there, installed from CD.

Machine: PowerMacintosh G3 Desktop
Processor: G4 ZIFF upgrade
Memory: 416 MB
Root Device: <IDE? SCSI? Name of device?> IDE Quantum Fireball 30GB
Root Size/partition table:

# type name length base ( size ) system
/dev/hda1 Apple_partition_map Apple 63 @ 1 ( 31.5k) Partition map
/dev/hda2 Apple_Driver_ATA Macintosh 54 @ 64 ( 27.0k) Unknown
/dev/hda3 Apple_Driver_ATA Macintosh 74 @ 118 ( 37.0k) Unknown
/dev/hda4 Apple_Driver_IOKit Macintosh 512 @ 192 (256.0k) Unknown
/dev/hda5 Apple_Patches Patch Partition 512 @ 704 (256.0k) Unknown
/dev/hda6 Apple_Bootstrap boot 195313 @ 1216 ( 95.4M) NewWorld bootblock
/dev/hda7 Apple_HFS untitled 2 6297647 @ 51461379 ( 3.0G) HFS
/dev/hda8 Apple_UNIX_SVR2 swap 1562501 @ 196529 (762.9M) Linux swap
/dev/hda9 Apple_UNIX_SVR2 var 1953126 @ 49508253 (953.7M) Linux native
/dev/hda10 Apple_UNIX_SVR2 home 9765626 @ 39742627 ( 4.7G) Linux native
/dev/hda11 Apple_UNIX_SVR2 usr 29296876 @ 1759030 ( 14.0G) Linux native
/dev/hda12 Apple_UNIX_SVR2 local 8686721 @ 31055906 ( 4.1G) Linux native
/dev/hda13 Apple_UNIX_SVR2 tmp 97657 @ 57759026 ( 47.7M) Linux native
/dev/hda14 Apple_Free Extra 824037 @ 57856683 (402.4M) Free space

Block size=512, Number of Blocks=58680720
DeviceType=0x0, DeviceId=0x0
1: @ 64 for 21, type=0x701
2: @ 118 for 34, type=0xf8ff

* Installer created NewWorld bootblock for root partition. Then quik bootloader would not install on this Mac. Was able to continue with installation but was unable to boot directly into Linux. Could not work a fix for OpenFirmware. Have used a duel boot system with BootX defaulting to Linux. Have so far been happy with this as there has been no need to reboot system very often.

Output of lspci:

0000:00:00.0 Host bridge: Motorola MPC106 [Grackle] (rev 40)
0000:00:0d.0 USB Controller: Silicon Image, Inc. (formerly CMD Technology Inc) USB0670 (rev 06)
0000:00:0e.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev 46)
0000:00:0f.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:00:10.0 ff00: Apple Computer Inc. Heathrow Mac I/O (rev 01)
0000:00:12.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro 215GP (rev 5c)

and lspci -n:

0000:00:00.0 0600: 1057:0002 (rev 40)
0000:00:0d.0 0c03: 1095:0670 (rev 06)
0000:00:0e.0 0c00: 1106:3044 (rev 46)
0000:00:0f.0 0200: 10ec:8139 (rev 10)
0000:00:10.0 ff00: 106b:0010 (rev 01)
0000:00:12.0 0300: 1002:4750 (rev 5c)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked: [E] - had to fiddle with BootX as OpenFirmware boot off CD did not work.
Configure network HW: [O] - Auto detect Apple ethernet and Realtek 10/100 PCI card.
Config network: [O] - Have Airport extreme base station as router/DHCP server.
Detect CD: [O]
Load installer modules: [O]
Detect hard drives: [O]
Partition hard drives: [O]
Create file systems: [O]
Mount partitions: [O]
Install base system: [O]
Install boot loader: [E] - quik boot loader would not install on boot partition (oldworld mac)
Reboot: [O] - used BootX with a copy of Linux kernel copied to OS9 partition.

Could not install quik boot loader. Could not configure OpenFirmware to work properly. Even after referring to quik quirks page and NetBSD pages on this subject. Used BootX from OS9 to boot into Linux. Copied kernel from Linux to OS9 system folder for BootX to use.

<Description of the install, in prose, and any thoughts, comments and ideas you had during the initial install.>
Much easier to get things going than installing woody. GUI worked without any problems after reboot. base-config easier to use.
Sharing with other macs using Samba without problems. Initial problems were sorting out the partitioning program and installing base system. Quik bootloader would not install but was able to continue installation and finally reboot to finish installation. It's working even if the mac doesn't boot directly into Linux due to unresolved OpenFirmware issues that I can't seem to sort out.

It's given new life to an old Mac that is now a file/web server for my home network.

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: