[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#267951: marked as done (Installation report Thinkpad X20)

Your message dated Wed, 08 Sep 2010 03:57:35 +0000
with message-id <E1OtBmx-0003tz-TC@ravel.debian.org>
and subject line Closing old installation report #267951
has caused the Debian Bug report #267951,
regarding Installation report Thinkpad X20
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

267951: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=267951
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports


Debian-installer-version: yesterday,
uname -a: 
Linux ebbjw 2.4.26-1-686 #1 Thu Jul 22 13:00:49 JST 2004 i686 GNU/Linux
Date: today
Method: How did you install?  What did you boot off?  If network
      install, from where?  Proxied?

netinst CD, booted from an extern USB CD, installed base system, rest from
the network

Machine: Thinkpad x20
Processor: 600 MHz PIII
Memory: 192MB
Root Device: IDE
Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.

Disk /dev/hda: 12.0 GB, 12068904960 bytes
15 heads, 63 sectors/track, 24944 cylinders
Units = cylinders of 945 * 512 = 483840 bytes

   Device Boot      Start         End      Blocks   Id  System
   /dev/hda1   *           1        8267     3906126   83  Linux
   /dev/hda2            8268        9300      488092+  82  Linux swap
   /dev/hda3            9301       24944     7391790   83  Linux

Output of lspci and lspci -n:

0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host
bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge
(rev 03)
0000:00:07.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 03)
0000:00:08.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
0000:00:08.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev 80)
0000:00:0a.0 Ethernet controller: 3Com Corporation 3c556B CardBus [Tornado]
(rev 20)
0000:00:0a.1 Communication controller: 3Com Corporation Mini PCI 56k
Winmodem (rev 20)
0000:00:0b.0 Multimedia audio controller: Cirrus Logic Crystal CS4281 PCI
Audio (rev 01)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility
P/M AGP 2x (rev 64)

0000:00:00.0 0600: 8086:7190 (rev 03)
0000:00:01.0 0604: 8086:7191 (rev 03)
0000:00:07.0 0680: 8086:7110 (rev 02)
0000:00:07.1 0101: 8086:7111 (rev 01)
0000:00:07.2 0c03: 8086:7112 (rev 01)
0000:00:07.3 0680: 8086:7113 (rev 03)
0000:00:08.0 0607: 1180:0476 (rev 80)
0000:00:08.1 0607: 1180:0476 (rev 80)
0000:00:0a.0 0200: 10b7:6056 (rev 20)
0000:00:0a.1 0780: 10b7:1007 (rev 20)
0000:00:0b.0 0401: 1013:6005 (rev 01)
0000:01:00.0 0300: 1002:4c4d (rev 64)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [E]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


1) my network card did not work -- the 3com 556b.  This seems to be a 2.6
kernel issue. After I have (much later) installed the 2.4, everything
started working fine.  But during the installation process I had a hard
time.  It seems to me that the installer does not handle such problem

  a) it did detect my network card, but id did not notice that it does not
  work and did not let me choose another card, a PCMCIA 3com card I have.  
  b) after the reboot, my settings were lost, and I could not
  c) ...come back to the installation step for choosing the ethernet
  card!!!  This was very, very annyoing.

I switched to another console and installed the PCMCIA card manually.  It
worked, but imagine a situation like this: the alternative card requires
some kernel modification or installing a different version of the kernel,
and I need to reboot -- will the installer start again after the reboot?
Or can I restart it manually?

A possibility to get back to the initial settings would be great.

Finally, I am no linux wizard, and though I was able to configure the
network manually, I was not able to configure the DHCP client, so I had to
put in static settings.  What if I did not know them and had to rely on the
DHCP client?  I would have been totally lost.

*AND* I could not check what is wrong, because the basic installation does
not contain ssh nor a simple text browser (lynx, links, w3m) --- I mean,
come on.  Those things are not huge but the impact of their absence is.
Nowadays a system is not working if it lacks ssh (where can you log in
using telnet?  Surely, not a single one of my machines).  Hey, ssh is not
even contained in the default package selection later on!!!  

Speaking of liver -- package selection.  Sorry, but the installer does not
even *ask* whether to start all those services it has installed.  I mean,
hello: I want to have netatalk "just in case", but starting it as a default
is, well, not a good idea.  Not to mention
  god knows what else.

I suggest to add an additional installation step asking for services which
should be started, and which not.

What was finally a bugger to install -- well, XFree.  Sorry, guys, it just
doesn't work.  The installer asks for some rudimentary settings (like
screen resolution) and then ignores them.  I have installed gpm and
effectively screwed up something -- mouse worked or not more or less
randomly until I have removed gpm.  I mean, come on.  A working mouse is
the least I expect from a basic install.

xf86cfg writes (as a default, when started from the console) the settings
not in /etc/X11/XF86Config-4, and it took me a little while to notice why
my settings remain with no effect.  Yeah, I know, he asks me for the file
to write the settings to (/usr/X11R6/lib/X11/XF86Config) but I thought that
/etc/X11/XF86Config-4 is a symlink to that file.  I am used to the
comfortable and userfriendly SaX (from SuSE) -- take a look at it, because
besides being well-tought it helps you much in configuring XFree by
guessing a lot of settings pretty well (as opposed to your configurator and
xf86cfg).  By the way -- xf86cfg cannot be used w/o a mouse with my laptop.
It just ain't physically possible to hold a mouse button down and move it
to choose a menu entry using a laptop keyboard.  At least in my Thinkpad
x20.  (or maybe I am dumb)

Ah, and by the way -- I am by no means a KDE user (Windowmaker is my
current choice), but I was not able to start KDE -- it just hangs there
with a grey screen and a lonely cursor in the middle of it.  Ah, yes, it
did ask me for personalization settings.  It suggested Zimbabwe as my
current location.  I know Poland is also pretty far from the center of the
World, but I did choose "Warsaw/Poland", german keyboard and US English
language during the installation and I expect this settings to be default
during all further personalisations/customizations etc.

Furthermore, using xf86cfg I managed to kill my XFree.  Well, not directly,
but there was no keyboard access, so I could not 
  change to another console
  kill Xwindows
  kill gdm

Remember that sshd is not started by default, not even installed by
default?  Well, I did install it, so I could log into my machine and kill X
from there.  But I think you see the problem here.  My suggestion would be:
ask the user whether he wants to start gdm/xdm right away.

But otherwise it was not all that bad -- note that I am much spoiled by the
quality of SuSE installers (I'm not talking about the quality of the system
here, just the quality of the installer).


Koniec i bomba, a kto czytal ten traba

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: