[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#265996: marked as done ([mips] [rc1] [netinst] serial install)

Your message dated Wed, 08 Sep 2010 03:57:34 +0000
with message-id <E1OtBmw-0003ro-Ua@ravel.debian.org>
and subject line Closing old installation report #265996
has caused the Debian Bug report #265996,
regarding [mips] [rc1] [netinst] serial install
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

265996: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=265996
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports


Debian-installer-version: rc1, downloaded from ftp.au.debian.org.
uname -a: Linux metebelis 2.4.26-r4k-ip22 #1 Sun Jul 18 20:49:31 UTC 2004
          mips GNU/Linux
Date: Sun Aug 15, 5pm GMT+10
Method: Installed over a serial console (no keyboard or monitor) using
        bootp/tftp.  Serial cable from the mips box was connected to an 
        i386 machine running minicom, where i did the actual typing.
        dhcp server and tftp server were on a third box (i386/sid), all
        on a local subnet.  Debian packages were downloaded from
        ftp.au.debian.org, no proxy used.

Machine: SGI Indy
Processor: R4600, 133MHz
Memory: 64M
Root Device: SCSI (/dev/sda)
Root Size/partition table: 1.06G in size.
                           Approx. 16M for SGI volhdr (part. 9),
                           then approx. 590M for / (ext3) (part. 1),
                           then approx. 418M swap (part. 2).
Output of lspci and lspci -n:
        metebelis:~# lspci
        pcilib: Cannot open /proc/bus/pci
        lspci: Cannot find any working access method.
        metebelis:~# lspci -n
        pcilib: Cannot open /proc/bus/pci
        lspci: Cannot find any working access method.

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [*] (worked with difficulties)
Create file systems:    [*] (worked with difficulties)
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


Mostly went very smoothly -- I was quite pleasantly surprised I could
do the entire installation over a serial console without a monitor or

Biggest difficulty was partitioning.  The machine originally came with irix
installed, and the machine already had four partitions (1:boot, 2:swap,
9:volhdr and 11:volume(iirc)).

I deleted partitions 1, 2 and 9 and recreated them with different sizes.
I then went on to the next d-i stage (create filesystems), and I was given an
error that there were no partitions available for creating filesystems on
(iirc -- alas I didn't write this down).  I went back to the partitioner and
deleted all four partitions (1,2,9,11).  I recreated 1, 2 and 9 and found
that 11 had automagically recreated itself (though with 1010 sectors instead
of the original 1011 from the initial irix partitioning).  d-i was then quite
happy to carry on from here.

One problem I did have with the partitioner was that you couldn't read the
full partition table on an 80-column terminal.  The device names were
so long (/dev/scsi/host0/bus0/target1/lun0/part1, etc.) that the table
was pushed too far to the right -- the partition size was obfuscated,
and anything to the right of it (such as the partition type) could not be
read at all.

The other trouble I had was during package configuration over the serial
console, in that I could not always see what options I was choosing
during the base system configuration.

Specifically, when running minicom from a konsole under X, the bold text
looked identical to standard text; as a result I was working blind in the
list selections (e.g., which timezone are you in, how do you want
exim to handle your mail).  When running minicom from tty1 I could handle
the lists fine (since the bold showed up), but some yes/no choices were
unclear (e.g., does your hardward clock use GMT) -- there was no indication
of which option i currently had selected.  In both the konsole and tty1
scenarios, the list of tasks (devel, desktop, manual package selection, etc)
gave no indication as to where my cursor was -- I had to press space at
random intervals to see which option changed state so i could navigate.

Perhaps these navigation issues could be improved by using a visual feedback
that does not rely on cursor position and font attributes alone?  An example
might be an asterisk that moves up and down a list (or between two buttons)
as you press the arrow keys.

All in all though, the installation was a very pleasant experience.  My
congratulations to the d-i team for such a smooth process.


--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: