[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#575662: marked as done (Tasksel)

Your message dated Wed, 31 Mar 2010 07:05:54 +0200
with message-id <201003310705.54930.elendil@planet.nl>
and subject line Re: Bug#575662: Tasksel
has caused the Debian Bug report #575662,
regarding Tasksel
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

575662: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=575662
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---

Package: Tasksel
Version: 2.78

I'm running Debian Lenny 2.6.26. I have a wierd problem with tasksel.
It seems that I can successfully install a package, and then when I return to tasksel browser, it automatically selects the recently installed package for removal. (Say bind9 for example)
If I quit tasksel, then next time I run it, the main menu defaults to the tasks that will remove the recently installed software (Say DNS server), and even when I choose manual software selection and return to the browser, it has again selected the package (Say bind9) (which was just successfully installed) for removal.
I find that I have this problem on two machines. Both machines have the same packages installed, and presumably the same versions since I've been downloading from stable main etc...yet each machine defaults to removing different packages (???)
It seems to me that tasksel is getting confused, or locked into a state that it thinks has unsatisfied dependencies, yet if that was the case, why would it have successfully installed the selected packages???
Anyways, its becoming a real pain in the arse because I have to keep telling it to NOT remove packages that have been successfully installed and are needed. I've tried searching around for solutions using tasksel, remove, force, keep, select...but obviously I get a whole lot of useless information.
Any suggestions????

All new Yahoo! Mail - Get a sneak peak at messages with a handy reading pane.
--- End Message ---
--- Begin Message ---
On Wednesday 31 March 2010, Christopher Buckley wrote:
> In my case, whenever I de-selected the DNS Server option on the main
> menu, it removed the bind9 package since bind9 IS the dns server
> package. 
> This is not a bug. It is by design.

Correct. Let's close it. Thanks for following up.


--- End Message ---

Reply to: