[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#572869: installation-reports: PowerMac G5 installation report: ofpath doesn't work in the absence of /proc/scsi/scsi

reassign 572869 yaboot 1.3.13a-1
clone 572869 -1
severity 572869 serious
reassign -1 yaboot-installer 1.1.15
block -1 by 572869
tag -1 help

Thanks for the report Branden.

On Sunday 07 March 2010, Branden Robinson wrote:
> Comments/Problems:
> Installation worked beautifully with the major exception of yaboot
> getting hopelessly confused.
> Evidently the ofpath utility has not been updated to handle the state of
> the world now that /proc/scsi/scsi is deprecated.  I had to dredge out
> old OpenFirmware references and manually edit /etc/yaboot.conf, then run
> mkofboot. This generation of PowerMacs (the very last :-( ) uses SATA
> drives on a PCI-E bus.
> Once I stuffed OpenFirware device-tree magic into yaboot.conf, things
> sprinted to a finish.  Even X worked on this foul NVidia device.
> Oddly, in rescue mode, the installer told me that installing yaboot
> failed, then told me it succeeded with the very next dialog.  Its first
> guess was correct; I had to implement the fix myself at a shell prompt.

This clearly needs a powerpc porter to look at. Therefore CCing the powerpc 

As the basic problem seems to be in ofpath, I'm reassigning to yaboot. 
ofpath will probably need to read sysfs instead of proc.

But it's quite likely that yaboot-installer will need to be updated as 
well. The D-I team itself is short on powerpc knowledge and hardware and 
unlikely to be able to fix this, therefore tagging help.

The place to start on the D-I side is the postinst script for 
yaboot-installer. The scripts in /lib/rescue.d/ will probably need 
updating as well. It's all shell script, so it should be simple enough.

A good starting point for hacking on Debian Installer is:
If any additional help is needed, please contact the debian-boot list.


Reply to: