[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#545162: GRUB installation bug

Package: installation-reports

Boot method: CD, the bussinescard ISO and I tried the netinst ISO
Image version: http://cdimage.debian.org/cdimage/daily-builds/daily/arch-latest/i386/iso-cd/debian-testing-i386-businesscard.iso
Date: 05.09.2009

Machine: PC Desktop Computer
Processor: AMD Athlon64 +3200
Memory: 2 GB Kingmax Memory
Partitions: 2 Partitions as used by the guided installer, it was a new hard drive

Output of lspci -knn (or lspci -nn):

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot: [O]
Detect network card: [O]
Configure network: [O]
Detect CD: [O]
Load installer modules: [O]
Detect hard drives: [O]
Partition hard drives: [O]
Install base system: [O]
Clock/timezone setup: [O]
User/password setup: [O]
Install tasks: [O]
Install boot loader: [E]
Overall install: [ ]

I have been using Lenny for 2 years now and decided it's time to switch to Squeeze by doing a fresh install. Here's the problem:

The installation hangs at the boot loader install stage. GRUB simply give a fatal error (after selecting that the loader should be installed
on the MBR - the yes or no question) message and the only way I can proceed further is by selecting the "Continue without boot loader option".
Upon restart I am booted in a GRUB prompt (GRUB >). I have tried to install Lenny with the corresponding Lenny images and the installation
went perfectly. So I guess this is a GRUB or D-I problem in Squeeze.

<Description of the install, in prose, and any thoughts, comments
and ideas you had during the initial install.>

Reply to: