[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: initrd woes

Maria McKinley wrote:
Well, no one said it was the wrong place to post, so I guess I will keep trying...

I made init non-executable, so that I would be dropped into a shell. Once in the shell, I tried running init from the command line, and maybe get some more info to use for troubleshooting than I was getting from running init from initrd. Here is what I got:

init s
init: /dev/initctl: No such file or directory

I read in some info about initctl that it is created by init. I looked at the documentation for init, but it was not clear to me what is run before the scripts in /etc/rcS.d. I tried putting an echo statement at the beginning of the first script in rcS.d, but it did not print, so I assume the problem is somewhere before this, but I don't know where to look. There is definitely a /dev/ directory that has lots of stuff in it (although not the initctl, of course), so not sure where the problem is. Can anyone give me a hint where to look now?


I figured out the /dev/initctl. I was attempting to start init the wrong way, I needed to do exec /sbin/init. When I tried that, I actually got it to boot up, although it has booted up still with the ro / mount and /usr mount made by initrd. It appears /etc/fstab was never read, because statd was never started. And of course, there are no log files since everything is read only, so I can't figure out what went wrong. And still have no idea why init wouldn't run at all from initrd. Please, any ideas?


Reply to: