[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Pre-bug-raising questions

Hi guys,

Many thanks for your closure of my recent bug to get the Sun LDOM
modules included into the Debian-installer (and the associated kernel

To further the process, I tried to do an install using the daily
netboot image at
I'm pleased to say that this gets further than ever before:

 - it fails to detect the network device but i'm able to select the
correct one from a list.
 - it fails to detect the disk device but i'm able to select the
correct one from a list.

(Don't know if the above 2 are a udev problem)

Anyway, both easily worked around.  The problem I get now is that the
kernel the installer installs as part of the setup is the etch-n-half
kernel, which doesn't have the required drivers installed.  So I'm
stuck at 'waiting for root filesystem...' until I drop to the initrd,
and I can't find the module to install.

Having some stuff randomly in my head about being able to pass suite=
to the boot line, I reinstalled with suite=lenny.

This time, the debian-installer installs a better sounding kernel
(2.6.26-1-sparc64-smp), but I'm dumped to the initrd shell again.
Looking through the filesystem, the modules are definitely there and I
can insmod them and continue the install.

Is there anything I'm missing here?  I can tell something is 'just a
bit missing' and I'd love to be able to raise a correct bug report for
this and get it squashed before Lenny.

Thanks for your help so far,


Reply to: