[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#510544: Installer/partition guide tried to use 500GB as swap

Quoting Christian Perrier <bubulle@debian.org>:


The installer/partition guide tried to use 500GB as swap space in my
encrypted volume group.

Could not use the auto partitioner, had to use a manual install...

I don't understand why you "had" to use a manual partitioning system...

Because the installer insisted to use 500GB as swap space and this couldnt be changed in the guided mode (or the installer menu is to complicated for me. If i tried to "configure lvm" or "configure encryption" it started with partitioning the 500GB swap).

What is the disk size and in what is having an encrypted swap space a

There is no problem with the encrypted swap. Its just too big.

Here is my setup after i used manual install:

# fdisk -l /dev/sda

Disk /dev/sda: 1500.3 GB, 1500301910016 bytes
255 heads, 63 sectors/track, 182401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00046c10

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          31      248976   83  Linux
/dev/sda2              32      182401  1464887025   8e  Linux LVM

# pvdisplay
  --- Physical volume ---
  PV Name               /dev/sda2
  VG Name               vg1
  PV Size               1.36 TB / not usable 1.74 MB
  Allocatable           yes (but full)
  PE Size (KByte)       4096
  Total PE              357638
  Free PE               0
  Allocated PE          357638
  PV UUID               NWeuY2-UJXF-ijQM-CKTe-yXGb-Djif-HMYT1G

# vgdisplay
  --- Volume group ---
  VG Name               vg1
  System ID
  Format                lvm2
  Metadata Areas        1
  Metadata Sequence No  9
  VG Access             read/write
  VG Status             resizable
  MAX LV                0
  Cur LV                2
  Open LV               2
  Max PV                0
  Cur PV                1
  Act PV                1
  VG Size               1.36 TB
  PE Size               4.00 MB
  Total PE              357638
  Alloc PE / Size       357638 / 1.36 TB
  Free  PE / Size       0 / 0
  VG UUID               6B0pNh-K6dR-Z0tK-FtuV-6mj7-0f83-QtcDc8

# ls /dev/mapper/
control  vg1-root  vg1-root_crypt  vg1-swap  vg1-swap_crypt

# df -h
Filesystem            Size  Used Avail Use% Mounted on
                      1.4T  425G  881G  33% /
/dev/sda1             236M   17M  207M   8% /boot

# cat /proc/swaps
Filename				Type		Size	Used	Priority
/dev/mapper/vg1-swap_crypt              partition	974840	76	-1

You apparently tried to use the "Guided - use entire disk and set up
encrypted LVM" option. Is that right?



Reply to: