[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#509238: panic backtrace

Quoting Christian Perrier <bubulle@debian.org>

>> Ok, tried a few more times.  I usually get the same kernel panic screen,

>Did you try in expert mode, ie choosing it from the "Advanced options"
>in the boot menu.

Yes, I tried expert as well as regular.

>In expert mode, when you reach the HW detection step, you'll get a
>question about PCMCIA options. They're not necessarily relevant but
>checking if the crash happens before or after it would help

No question about PCMCIA before getting to the network detection
screen/status bar.

> ...

>Some drivers in 2.6.18 provided firmware blobs that have been
>extracted from the source and are now provided as separate udebs:

>root@mykerinos:~> apt-cache search firmware 2100
>firmware-ipw2x00 - Binary firmware for Intel Pro Wireless 2100, 2200 and 2915

That explains the missing firmware.

>If that firmware is needed for ipw2100, you'll be prompted about
>this....but you're not, which means the crash happens before..:-)


>> Anything else I can do? More tests?

>Before the network devices screen (for instance, when prompted for
>language), could you switch to VT2 (Alt+F2) and, from there edit

>Add "-x" to the first line:

>#!/bin/sh -x

>Then go back to VT1, continue to the step where the crash happens and
>sitch to VT4 before it happens. As ethdetect.sh will be in debug mode,
>we'll see all its output and could narrow down the exact line where
>the crash happens.

Ok, did that and also vga=771.  I was hoping to get a smaller font to
see more of the backtrace.  This is what I got:

[ output of ethdetect -x - lsifaces (3 lines) sed (4), grep (4) and sed (3) ]
Dec 22 15:42:48 main-menu[1328]: (process:9628) + ip link set eth0 up
Dec 22 15:42:48 main-menu[1328]: (process:9628) + ip link set eth0 down
Dec 22 15:42:48 main-menu[1328]: (process:9628) + ip link set eth1 up
Dec 22 15:42:48 main-menu[1328]: (process:9628) + ip link set eth1 down
Dec 22 15:42:48 main-menu[1328]: (process:9628) + check-missing-firmware
Dec 22 15:42:48 main-menu[1328]: (process:9628) + sysfs-update-devnames
Dec 22 15:42:48 main-menu[1328]: (process:9628) + cleanup
Dec 22 15:42:48 main-menu[1328]: (process:9628) + rm -f /tmp/devnames-static.txt
Dec 22 15:42:48 main-menu[1328]: DEBUG: resolver (libslang2-udeb): package doesn't exist (ignored)

It didn't crash!  After that I proceeded to console 1 and did see the
screen explaining that I needed the missing firmware - ipw2100-1.3.fw.
As I had thought, even with the missing firmware, the culprit wasn't
the wireless device.

First thought: race condition (the panic message contained a backtrace
of different threads), so then I tried multiple times with only one
change at at time: expert mode, regular mode, ethdetect -x, vga=771,
vga normal.  It turns out that the culprit was the vga option.  With
vga=771, I get no crash/panic in either expert or regular mode, with
sh -x in ethdetect or not.  It might still be a race condition but if
so it seems to be triggered by something related to the display.  Very
strange.  The display works fine (with a big font) in normal mode.  In
771 mode, the font is smaller and the curses windows sharper.

Even though I now have a work-around, I'm willing to keep debugging
if if would be useful.

Reply to: