[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#509238: panic backtrace

Quoting Christian Perrier <bubulle@debian.org>
>OK. Are you in the position of testing with something else than a USB
>stick boot?

Actually, before I gave up on CDs (ruined 11 CD-Rs, probably marginal
media, drive or wodim problems) I had a CD made on a windows machine
of the lenny installer RC1.  This is what I just tried again.

I get the same panic at the same point in the installation process.
Of course the addresses are slightly different as the underlying
kernel code is different.

>The best would be using the "netboot" ISO (called mini.iso) from a CD.

> ...
>> Ok, it happens immediately after the identifying network hardware
>> screen.  So soon after in fact that I thought I would have no time to

>"after identifying network HW" means 'after the system displays a
>progress bar saying "Identifying network hardware", right?


>This is where we would need to really narrow things down and where
>using the expert mode could help.

Ok, tried a few more times.  I usually get the same kernel panic screen,
but on one occasion (in expert mode), it crashed a little differently
and I saw this:

Dec 21 17:21:46 kernel: [  173.096981] ipw2100: Intel(R) PRO/Wireless 2100 Network Driver, git-1.2.2
Dec 21 17:21:46 kernel: [  173.096987] ipw2100:
Dec 21 17:21:46 kernel: [  173.096987] ipw2100: Copyright(c) 2003-2006 Intel Corpration
Dec 21 17:21:46 kernel: [  173.206202] ACPI: PCI Interrupt 0000:02:03:0[A] -> Link [LKNB] -> GSI 5 (level, low) -> IRQ 5
Dec 21 17:21:46 kernel: [  173.206206] ipw2100: Detected Intel PRO/WIreless 2100 Network Connection
Dec 21 17:21:46 kernel: [  173.206619] firmware: requesting ipw2100-1.3.fw
Dec 21 17:21:46 net/hw-detect.hotplug: Detected hotpluggable network interface eth0
Dec 21 17:21:46 kernel: [  173.349107] ipw2100: eth1: Firmware 'ipw2100-1.3.fw' not available or load failed.
Dec 21 17:21:46 kernel: [  173.349114] ipw2100: eth1: ipw2100_get_firmware failed: -2
Dec 21 17:21:46 kernel: [  173.349118] ipw2100: eth1: Failed to power on the adapter.
Dec 21 17:21:46 kernel: [  173.349121] ipw2100: eth1: Failed to start the firmware.
Dec 21 17:21:46 kernel: [  173.349125] ipw2100Error calling register_netdev.
Dec 21 17:21:46 kernel: [  173.349443] ACPI: PCI interrupt for device 0000:02:03.0 disabled
Dec 21 17:21:46 kernel: [  173.349450] ipw2100: probe of 0000:02:03.0 failed with error -5
Dec 21 17:21:46 hw-detect: insmod /lib/modules/2.6.26-1-486/kernel/drivers ieee1394/sbp2.ko
Dec 21 17:21:46 kernel: [  173.480359] eth1394: eth1: IPv4 over IEEE 1394 (fw-host0)
Dec 21 17:21:46 net/hw-detect.hotplug: Detected hotpluggable network interface e

This is exactly as the screen froze.  I wonder if the only line visible that
refers to eth0 is when it actually detected the main (wired) ethernet
interface.  As this is the interface I want to use and it appears that it
generated no errors, it seems to be a good sign.  All the ipw2100 lines
refer to the wireless interface, which works fine on 2.6.18.  I never knew
it required separate firmware.  Since it appears not to be included in the
installer, I presume I'd have to find it in the additional drivers media.
In any case, the errors notwithstanding, it looks like the installer handled
the wireless interface correctly.  Am I right that it seems it's the
eth1394 driver that is causing the crash?

I've tried (based on the help example: hw-detect/start_pcmcia=false) to add
hw-detect/start_eth1394=false but it doesn't seem to have an effect.  It
still crashes.  BTW, the eth1394 driver is loaded without errors under
2.6.18, although it is not used.  I have no fire-wire devices to test it.
Early on, I passed the option to protect the firewire interface addresses
(faffd800 - faffdfff) but it still crashed.

I suppose it would help if I could get more lines in the console screens.
What option can I pass the installer to have smaller type, or even better
2 side by side pages?  I have a WUXGA (1920 X 1200) screen so it should be
possible to see a much longer backtrace.


>OK. Thanks for the help trying to narrow things. Being an obvious
>problem with the kernel, we really need to triple check that it
>happens or not with the last  kernel package from unstable (which is
>likely, but still...)

If you point me to a boot.img.gz of the latest kernel, that I can
zcat to the usb memory stick, I'd be happy to test it.

Anything else I can do? More tests?

Reply to: