[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#505516: marked as done (lilo-installer: XFS on / doesn't boot properly on amd64)

Your message dated Fri, 14 Nov 2008 06:52:01 +0100
with message-id <20081114055201.GU5764@mykerinos.kheops.frmug.org>
and subject line Re: Bug#505516: lilo-installer: XFS on / doesn't boot properly on amd64
has caused the Debian Bug report #505516,
regarding lilo-installer: XFS on / doesn't boot properly on amd64
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

505516: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505516
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: lilo-installer
Severity: important

Originally sent by Walte Landry in debian-boot..

Please note that this problem does not happen on x86...

----- Forwarded message from Walter Landry <wlandry@caltech.edu> -----

Date: Tue, 11 Nov 2008 11:50:38 -0800 (PST)
To: debian-boot@lists.debian.org
Subject: Lenny RC1: no XFS on /
From: Walter Landry <wlandry@caltech.edu>
X-Mailer: Mew version 6.0.51 on Emacs 22.2 / Mule 5.0 (SAKAKI)
X-Mailing-List: <debian-boot@lists.debian.org> archive/latest/136010
X-CRM114-Status: Good  ( pR: 47.0061 )


I just tried installing Lenny RC1 amd64 (business card and kde) on a
Lenovo Thinkpad W500.  I made all of the filesystems XFS, including
"/" (I do not have a separate /boot partition).  Upon rebooting, I got
the message:

  RAMDISK: Couldn't find valid RAM disk image starting at 0.
  List of all partitions:
  No filesystem could mount root, tried:
  Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,1)

When I reinstalled and made "/" ext3, it worked fine.

I have also been fiddling around with Lenny Beta2 and daily snapshots.
Lenny Beta2 can not detect my ethernet card (Intel Corporation 82567LM
Gigabit Network Connection).  The amd64 daily snapshot (Nov 6) has the
same issue with XFS on "/".  The i386 daily snapshot (Nov 10) does
not.  However, the i386 daily snapshot gui install gave me a strange

  Uhhuh.  NMI received for unknown reason 91 on CPU 0.
  You have some hardware problem, likely on the PCI bus.
  Dazed and confused, but trying to continue.

Besides that message, the gui install seemed to work fine.

In the course of all this, I noticed a few oddities about
repartitioning.  There was a partition that I wanted to expand to the
rest of the disk.  That would make the partition 178.49 GB.  But the
partitioner displayed 178.5.  If I tried to make it 178.5, then it
complained that I was going off of the end of the disk.  Even if I
just specified "max", it still said I was trying to go past the end of
the disk.

At one point, I managed to get into an infinite loop where it would
tell me about an error, but clicking "go back" or "continue" kept
bringing up the same errors.  I do not know how I got into that
situation, but I thought I should mention it.

The Thinkpad W500 has switchable ATI graphics (FireGL v5700).  In the
BIOS, I can set it to integrated, discrete, or switchable.  For the
"ati" and "radeon" drivers, I have to set it to discrete or the
drivers will not find the card.  This seems to be well known to
google, so I only mention it here for completeness.

As an aside, I never could get the fglrx drivers to work in 32 or 64
bit.  It would just blank the screen.

All in all, the experience was not so bad.  Much easier than last time
[1].  I still do not have wireless working (Intel 5300).  I have to
compile a 2.6.27 kernel for that.  The only real bug that I have to
report is that running with XFS on the boot partition on amd64 does
not work.

As a wishlist item, it would be nice if the partitioner handles ntfs
partitions better.  I wanted to move my original windows partition to
the end.  I could create a new partition, but I could not make it
ntfs.  I tried to copy all of the data from the partition, but it did
not comply.  So I ended up just deleting windows off of this machine.
So maybe it is not a bug after all ;)

If you have any questions, please let me know.  I am not subscribed to
this list.

Walter Landry

[1] http://lists.debian.org/debian-boot/2005/04/msg00034.html

To UNSUBSCRIBE, email to debian-boot-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org

 ** CRM114 Whitelisted by: WHITELIST **

----- End forwarded message -----


Attachment: signature.asc
Description: Digital signature

--- End Message ---
--- Begin Message ---
After discussion, we agreed that this bug is indeed #479607, which fix
should migrated to testing tomorrow.

Attachment: signature.asc
Description: Digital signature

--- End Message ---

Reply to: