[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#491737: marked as done (please allow selection of language)

Your message dated Sat, 16 Aug 2008 17:32:04 +0000
with message-id <E1KUPdE-0003Lv-2q@ries.debian.org>
and subject line Bug#491737: fixed in oldsys-preseed 2.2
has caused the Debian Bug report #491737,
regarding please allow selection of language
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

491737: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=491737
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports
Severity: normal

-- Package-specific info:

Boot method: From flash
Image version: http://people.debian.org/~joeyh/d-i/armel/images/20080721-10:10/orion5x/netboot/qnap/ts-109/
Date: <Date and time of the install>

Machine: QNAP TS-109 Pro II

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000b6b26

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1          31      248976   83  Linux
/dev/sda2              32      121507   975755970   83  Linux
/dev/sda3          121508      121601      755055    5  Extended
/dev/sda5          121508      121601      755023+  82  Linux swap / 

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [O]
Configure network:      [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Install base system:    [O]
Clock/timezone setup:   [O]
User/password setup:    [O]
Install tasks:          [O]
Install boot loader:    [O]
Overall install:        [O]


I decided to try installing Debian on a pristine QNAP TS-109 Pro II 
device, after getting a note from Martin Michlmayr that the images would 
be available. I had had the device for a few weeks waiting for Debian, 
since the vendor itself doesn't currently offer a possibility to install 
their own firmware without having a Windows or Mac OS license.

I connected with telnet to the device, inserted an USB stick, backuped 
mtd1 and mtd2 partitions and then run flash-debian from the stick. After 
rebooting I could ssh to the debian installer succesfully, and completed 
the installation without problems.

Only possible problem during installation I hit was that I wasn't able 
to choose Finnish as installation language. Maybe a feature of this 
installation method, not a bug? At one point there was possibility to 
choose language, I think -  it asked for the continent and country but 
then continued when I selected Finland without giving a choice of 
language. After the installation, I ran dpkg-reconfigure locales 

After installation I did encounter problems with using external disks:
- System hang whenever either eSATA disk or USB disk was connected or 
- Booting with either already connected was succesful and the disk was 
- However, some directories were not accessible. All unaccessible 
directories seemed to (at a casual look) have special characters in 
their names, but many similar named directories worked without problems. 
For example (from my FLACd CD collection):
d?????????  ? ?    ?        ?         ? Björk - Telegram
d?????????  ? ?    ?        ?         ? Ø - Metri

I checked that the disk still works as it should be when connected to my 
desktop machine either directly or using the same eSATA/USB 3.5" HDD 
case I used for connecting to QNAP.

I heard that the sata_mv is experimental in 2.6.25 and had major 
improvements in 2.6.26, which would explain eg. the eSATA problem, but 
what about having the same problem when connecting the external disk via 
USB? Anyway, I guess I have to wait for 2.6.26 kernel to check if these 
are fixed.

Other than these problems, everything has seemingly worked well for now.


Installer lsb-release:
DISTRIB_DESCRIPTION="Debian GNU/Linux installer"
DISTRIB_RELEASE="5.0 (lenny) - installer build 20080721-09:47"

Installer hardware-summary:
umame -a: Linux debian 2.6.25-2-orion5x #2 Sat Jun 28 16:52:36 UTC 2008 armv5tel unknown
lsmod: Module                  Size  Used by
lsmod: reiserfs              258740  0 
lsmod: ext3                  137160  1 
lsmod: jbd                    49236  1 ext3
lsmod: vfat                   13088  0 
lsmod: fat                    53980  1 vfat
lsmod: nls_base                7520  2 vfat,fat
lsmod: usb_storage            89351  0 
lsmod: evdev                  11776  0 
lsmod: gpio_keys               4192  0 
lsmod: ext2                   73000  1 
lsmod: mbcache                 9024  2 ext3,ext2
lsmod: sd_mod                 29776  4 
lsmod: sata_mv                25452  3 
lsmod: libata                154364  1 sata_mv
lsmod: ehci_hcd               36908  0 
lsmod: scsi_mod              158852  3 usb_storage,sd_mod,libata
lsmod: usbcore               138780  3 usb_storage,ehci_hcd
lsmod: mv643xx_eth            23076  0 
lsmod: mii                     5760  1 mv643xx_eth
df: Filesystem           1k-blocks      Used Available Use% Mounted on
df: tmpfs                   128520        40    128480   0% /dev
df: tmpfs                   128520        40    128480   0% /dev
df: /dev/sda2            960444488    741336 910915356   0% /target
df: /dev/sda1               233335      9245    211642   4% /target/boot
df: /dev/sda2            960444488    741336 910915356   0% /dev/.static/dev
df: tmpfs                   128520        40    128480   0% /target/dev
free:               total         used         free       shared      buffers
free:   Mem:       257044       212896        44148            0        18072
free:  Swap:       755012            0       755012
free: Total:      1012056       212896       799160
/proc/cpuinfo: Processor	: Feroceon rev 0 (v5l)
/proc/cpuinfo: BogoMIPS	: 332.59
/proc/cpuinfo: Features	: swp half thumb fastmult edsp 
/proc/cpuinfo: CPU implementer	: 0x41
/proc/cpuinfo: CPU architecture: 5TEJ
/proc/cpuinfo: CPU variant	: 0x0
/proc/cpuinfo: CPU part	: 0x926
/proc/cpuinfo: CPU revision	: 0
/proc/cpuinfo: Cache type	: write-back
/proc/cpuinfo: Cache clean	: cp15 c7 ops
/proc/cpuinfo: Cache lockdown	: format C
/proc/cpuinfo: Cache format	: Harvard
/proc/cpuinfo: I size		: 32768
/proc/cpuinfo: I assoc		: 1
/proc/cpuinfo: I line length	: 32
/proc/cpuinfo: I sets		: 1024
/proc/cpuinfo: D size		: 32768
/proc/cpuinfo: D assoc		: 1
/proc/cpuinfo: D line length	: 32
/proc/cpuinfo: D sets		: 1024
/proc/cpuinfo: Hardware	: QNAP TS-109/TS-209
/proc/cpuinfo: Revision	: 0000
/proc/cpuinfo: Serial		: 0000000000000000
/proc/ioports: 00000000-000fffff : PCI-EX I/O Space
/proc/ioports: 00100000-001fffff : PCI I/O Space
/proc/iomem: 00000000-07ffffff : System RAM
/proc/iomem:   00023000-0028bfff : Kernel text
/proc/iomem:   0028c000-002e12f3 : Kernel data
/proc/iomem: 10000000-17ffffff : System RAM
/proc/iomem: e0000000-e7ffffff : PCI-EX Memory Space
/proc/iomem: e8000000-efffffff : PCI Memory Space
/proc/iomem: f1011000-f101101f : i2c base
/proc/iomem:   f1011000-f101101f : mv64xxx_i2c adapter
/proc/iomem: f1012000-f10120ff : serial8250.0
/proc/iomem:   f1012000-f101201f : serial
/proc/iomem: f1012100-f10121ff : serial8250.0
/proc/iomem:   f1012100-f101211f : serial
/proc/iomem: f1050000-f1051000 : orion-ehci.0
/proc/iomem:   f1050000-f1051000 : ehci_hcd
/proc/iomem: f1072000-f1073fff : mv643xx_eth_shared.
/proc/iomem: f1080000-f1084fff : sata base
/proc/iomem: f10a0000-f10a1000 : orion-ehci.1
/proc/iomem:   f10a0000-f10a1000 : ehci_hcd
/proc/iomem: f4000000-f47fffff : physmap-flash.0
/proc/iomem:   f4000000-f47fffff : physmap-flash.0
/proc/interrupts:            CPU0
/proc/interrupts:   0:     366435  Orion-IRQ-Main  orion_tick
/proc/interrupts:   3:       1509  Orion-IRQ-Main  serial
/proc/interrupts:   5:       9135  Orion-IRQ-Main  mv64xxx_i2c
/proc/interrupts:  12:         26  Orion-IRQ-Main  ehci_hcd:usb2
/proc/interrupts:  17:          0  Orion-IRQ-Main  ehci_hcd:usb1
/proc/interrupts:  21:     103530  Orion-IRQ-Main  eth0
/proc/interrupts:  29:     188504  Orion-IRQ-Main  sata_mv
/proc/interrupts:  33:          0  Orion-IRQ-GPIO  USB Copy Button
/proc/interrupts:  34:          1  Orion-IRQ-GPIO  Reset Button
/proc/interrupts: Err:          0
/proc/meminfo: MemTotal:       257044 kB
/proc/meminfo: MemFree:         44088 kB
/proc/meminfo: Buffers:         18072 kB
/proc/meminfo: Cached:         173740 kB
/proc/meminfo: SwapCached:          0 kB
/proc/meminfo: Active:          67992 kB
/proc/meminfo: Inactive:       128400 kB
/proc/meminfo: SwapTotal:      755012 kB
/proc/meminfo: SwapFree:       755012 kB
/proc/meminfo: Dirty:             288 kB
/proc/meminfo: Writeback:           0 kB
/proc/meminfo: AnonPages:        4556 kB
/proc/meminfo: Mapped:           2780 kB
/proc/meminfo: Slab:            13020 kB
/proc/meminfo: SReclaimable:     8712 kB
/proc/meminfo: SUnreclaim:       4308 kB
/proc/meminfo: PageTables:        304 kB
/proc/meminfo: NFS_Unstable:        0 kB
/proc/meminfo: Bounce:              0 kB
/proc/meminfo: CommitLimit:    883532 kB
/proc/meminfo: Committed_AS:     9392 kB
/proc/meminfo: VmallocTotal:   606208 kB
/proc/meminfo: VmallocUsed:      8640 kB
/proc/meminfo: VmallocChunk:   589820 kB
/proc/bus/input/devices: I: Bus=0019 Vendor=0001 Product=0001 Version=0100
/proc/bus/input/devices: N: Name="gpio-keys"
/proc/bus/input/devices: P: Phys=gpio-keys/input0
/proc/bus/input/devices: S: Sysfs=/class/input/input0
/proc/bus/input/devices: U: Uniq=
/proc/bus/input/devices: H: Handlers=kbd event0 
/proc/bus/input/devices: B: EV=3
/proc/bus/input/devices: B: KEY=1000000 0 0 0 0 0 0 0 0 100000 0 0 0

-- System Information:
Debian Release: lenny/sid
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: armel (armv5tel)

Kernel: Linux 2.6.25-2-orion5x
Locale: LANG=fi_FI.UTF-8, LC_CTYPE=fi_FI.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

--- End Message ---
--- Begin Message ---
Source: oldsys-preseed
Source-Version: 2.2

We believe that the bug you reported is fixed in the latest version of
oldsys-preseed, which is due to be installed in the Debian FTP archive:

  to pool/main/o/oldsys-preseed/oldsys-preseed_2.2.dsc
  to pool/main/o/oldsys-preseed/oldsys-preseed_2.2.tar.gz
  to pool/main/o/oldsys-preseed/oldsys-preseed_2.2_armel.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 491737@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Martin Michlmayr <tbm@cyrius.com> (supplier of updated oldsys-preseed package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.8
Date: Sat, 16 Aug 2008 20:12:49 +0300
Source: oldsys-preseed
Binary: oldsys-preseed
Architecture: source armel
Version: 2.2
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Martin Michlmayr <tbm@cyrius.com>
 oldsys-preseed - Preseed debian-installer from an existing device (udeb)
Closes: 491737
 oldsys-preseed (2.2) unstable; urgency=low
   * No longer preseed debian-installer/locale to allow the selection
     of a language.  Closes: #491737.
   * Set DEBCONF_DROP_TRANSLATIONS=0 if we're not in lowmem mode so
     translations will be kept.
   * test suite: test for a (invalid) hostname containing space.
   [ Per Andersson ]
   * Fix parsing of the hostname on the Kurobox Pro: don't output the
     hostname twice, leading to an invalid preseed file.
 1e0d4e638f44d97b101004136ff1dc4ab7e3ece0 866 oldsys-preseed_2.2.dsc
 3967be0151fdfd903cfb2d076fd58859c78a1da6 292559 oldsys-preseed_2.2.tar.gz
 698d8d676ebe0ff1a349c800e43bb9dbcf9e6732 5420 oldsys-preseed_2.2_armel.udeb
 1a8dd92abcd0865a869c7ad2d66ed64e57be5c55b5e7166ed8cf2887198d2d4a 866 oldsys-preseed_2.2.dsc
 3ccc198d7364f5fb5caff5c186ce02ed62769783d1fdf4596406555a69dcbf78 292559 oldsys-preseed_2.2.tar.gz
 9118ac03ef150dfb660606d0491242a01309143622c5cc1af4431fd83b1bcdc3 5420 oldsys-preseed_2.2_armel.udeb
 3d8afcd77ec0f9f93b8df0a7eceda843 866 debian-installer optional oldsys-preseed_2.2.dsc
 0265836fa32cdfd9b5200697263593a2 292559 debian-installer optional oldsys-preseed_2.2.tar.gz
 ca9ce085e38d8668a08d075a9c493ff9 5420 debian-installer optional oldsys-preseed_2.2_armel.udeb
Package-Type: udeb

Version: GnuPG v1.4.9 (GNU/Linux)


--- End Message ---

Reply to: