[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

libparted-1.8.so missing?


i am trying to perform a (preseeded hands-off network) install with Debian 
Installer on a machine has a local scsi disk and two FC adapters "seeing" 
many devices (16 each).

One problem is that each time i boot the local disk (on which i want to 
install Debian) gets another device name, sometimes /dev/sdq or /dev/sdag, 
or even /dev/sda once. 

  ==> is there a way to prevent that, get the kernel to "put" the local 
disk in /dev/sda ?  (i preseed with "d-i partman-auto/disk 
string /dev/sdag"  but of course it doesn't help if the device name is 

Anyways, even if i get (by chance) the right partman-auto/disk  value, the 
install breaks at the partitioning step, and in the console i see:

  "parted-server: error while loading shared libraries: libparted-1.8.so.9:
   cannot open shared object file: No such file or directory"

What could be going wrong?  I am using the daily netboot snapshot for 
amd64, but also tried the Lenny beta 3 version, same happens.
I also tried changing
  d-i     mirror/suite            string lenny
  #d-i    mirror/udeb/suite       string unstable

it doesn't seem to help...   I couldn't find anything relevant after a lot 
of searching in google and in the debian lists. 

Thanks for any tip!
(PS: Please CC me directly as i am currently not subscribed.)


Reply to: