[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#484366: rootskel: cttyhack requires the serial console to be /dev/ttyS0

On Wed, Jun 04, 2008 at 03:21:41PM +0200, Frans Pop wrote:
> On Tuesday 03 June 2008, Daniel Jacobowitz wrote:
> > I tried to install Debian on Versatile/PB using qemu and the armel
> > installer (Lenny beta 1).  It is quickly stuck complaining
> > "cttyhack: '/dev/ttyS0': No such file or device".
> What _exact_ qemu command line did you use?
> How did you connect to the "ttyAMA0" serial port? Using minicom or 
> something on the same host system, from a different system or what?
> Note that D-I works just fine if you just let it run inside a qemu window.
> I'm not yet convinced that there is either an installer bug or a busybox 
> bug here.

If you just run qemu, and SDL was available when it was built, you get
a graphical window including qemu's console and a real TTY.  So there's no
serial console involved at all.

My qemu was built without SDL, and I ran it with -nographic.  Either
of those is sufficient to end up with a serial console install,
effectively headless.  qemu's standard input and output are the serial

The qemu command was:

qemu-system-arm -m 256 -M versatilepb -kernel qemu-kernel-image \
  -initrd initrd.gz -append "mem=256M console=ttyAMA0 root=/dev/ram" \
  -hda qemu-disk-image -nographic

Daniel Jacobowitz

Reply to: