[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Network failure on install/boot

Dear Debian Team!

I encountered a vital problem with my network card while installing debian 4.0r1 (kernel 2.6.18-5-486) from CD-ROM on an old Pentium system. As I believe, this might be a bug, but I'm not sure.

I tried to install the system in expert mode while being physically connected to my LAN. All steps until "Detect network hardware" went OK. On "Configure the network" the installation stopped unexpectedly. When I selected "no DHCP" I was left with a blue screen after confirming the summary of IP, DNS, and so on. This bluesceen wouldn't disappear for hours and there was no other way then pushing the power button. Next try of installation I selected "use DHCP", and the status bar of "Configuring using DHCP" would run until 6% and then stop there (for at least 15 minutes). Again, I quit the installation with the power button.

Next I tried to install the system with no LAN cable connected to the PC. This time the installation went all right (no GUI installed). The system boots from hard disk as long as no LAN cable is connected. The NIC seems to be loaded ok, as ifconfig outputs the interface as eth0.

However, if a cable is connected at boot, the boot process gets stuck filling up the screen with the error message: "eth0: PCI Bus error 2280." If I boot with no cable, and plug in the cable when being prompted for login, the message "eth0: link up, 100Mbps, full duplex, lpa 0x45E1" appears immediately. After approx 15 seconds the screen will be filled up with "eth0: PCI bus error 2280" again and there is no way to bring the system down safely. Not even "Ctrl+Alt+Print+ R E I S U B" helps.

To exclude the opportunity that neither the NIC itself, nor the PCI interface is faulty, I did the following:
- I tested the NIC in another system, running Ubuntu 7.10 (kernel 
  2.6.22-14-generic) and it worked no worries.
- I tried a different PCI slot for the NIC with the same result as before.
- I tried a different NIC in the same slot with the same result.
- I tried a different PCI card (graphics adapter) in the same PCI slot as
  the NIC is connected to now. The graphic adapter worked as it should.

I would be very thankful, if one of you could give me a hint on how to solve this problem. Please let me know how to produce more output that could be helpful to you.

Sincerely yours,
Holger Schmithüsen, Germany
Ist Ihr Browser Vista-kompatibel? Jetzt die neuesten 
Browser-Versionen downloaden: http://www.gmx.net/de/go/browser

Reply to: