[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#440161: marked as done (wrong /etc/fstab when installing on RAID using Adaptec 2100S)

Your message dated Mon, 24 Mar 2008 17:02:07 +0000
with message-id <E1Jdq3j-0002We-2n@ries.debian.org>
and subject line Bug#440161: fixed in kernel-wedge 2.42
has caused the Debian Bug report #440161,
regarding wrong /etc/fstab when installing on RAID using Adaptec 2100S
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

440161: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=440161
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: debian-installer
Version: 20070308

I recently used d-i to install etch on a FujituSiemens Primergy F200. That maschine has 6 SCSI-Drives built-in, which i have configured as RAID5 (no Hotspare) using the Adaptec-BIOS. During POST and installation the RAID-Array is shown as /dev/sda.

Then i have created a ext3-Partition /dev/sda1 for /boot and a LVM on /dev/sda5 using the rest of the Array-capacity for /.

Installation proceeded fine.

After rebooting the maschine, everything worked fine. System found LVM and could mount it correctely, but then failed to mount /boot (which is on /dev/sda1 - as i thought).

I found out, that for the Adaptec 2100S the modules i2o-core and i2o-block are loaded. The modules find the Adapter correctely.

But my /boot-partition - formerly known as /dev/sda1 - could now be found at /dev/i2o/hda1 after loading the i2o-modules.

After changing the line in /etc/fstab from
/dev/sda1	/boot [...]
/dev/i2o/hda1	/boot [...]
and rebooting the maschine - it worked!

Dont know, if that is a problem in d-i or in i2o...

--- End Message ---
--- Begin Message ---
Source: kernel-wedge
Source-Version: 2.42

We believe that the bug you reported is fixed in the latest version of
kernel-wedge, which is due to be installed in the Debian FTP archive:

  to pool/main/k/kernel-wedge/kernel-wedge_2.42.dsc
  to pool/main/k/kernel-wedge/kernel-wedge_2.42.tar.gz
  to pool/main/k/kernel-wedge/kernel-wedge_2.42_all.deb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 440161@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Otavio Salvador <otavio@ossystems.com.br> (supplier of updated kernel-wedge package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Mon, 24 Mar 2008 13:52:43 -0300
Source: kernel-wedge
Binary: kernel-wedge
Architecture: source all
Version: 2.42
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Otavio Salvador <otavio@ossystems.com.br>
 kernel-wedge - udeb package builder for Debian-Installer
Closes: 440161 469143
 kernel-wedge (2.42) unstable; urgency=low
   [ Otavio Salvador ]
   * Replace dpt_i2o with i2o_block to avoid diverting from installed
     system with regard to RAID with Adaptec 2100S. Closes: #440161.
   * Add ipg, niu, ixgbe, e1000e, sky2 and skge to nic-extra-modules.
     Closes: #469143
   * Move b44 to nic-pcmcia-modules.
   * Add zlib-modules udeb to provide zlib_inflate to ide and ppp
   * Add p54pci and p54usb to nic-wireless-modules.
   [ Stephen R. Marenka ]
   * add aes_generic, make aes optional to accommodate 2.6.24.
   * add sha256_generic, make sha256 optional to accommodate 2.6.24.
   * make ppp_async and ppp_synctty optional to accommodate m68k/mac.
 7639515eb1d2b07c7ca9238481490ede 670 utils optional kernel-wedge_2.42.dsc
 0952c8f6e7abd651f62118c66783fed5 37624 utils optional kernel-wedge_2.42.tar.gz
 7110f7d1bee2c37fbc9d9f65122d1bb4 42614 utils optional kernel-wedge_2.42_all.deb

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---

Reply to: