[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#470840: debian-installer: Fails to install Grub on a RAID5 system

Package: debian-installer
Version: 4.0r3
Severity: critical
Justification: breaks the whole system

I installed a debian stable system on a Pentium 4 machine with 4 320GB ide disks and the installation goes well,
but when it comes to installing grub on the MBR i get an error and i cannot continue.
The raid array is set up like this:

 root@amaro:/# mdadm --query --detail /dev/md0 
        Version : 00.90.03
  Creation Time : Thu Mar 13 16:58:31 2008
     Raid Level : raid5         
     Array Size : 624028544 (595.12 GiB 639.01 GB)
    Device Size : 312014272 (297.56 GiB 319.50 GB)
   Raid Devices : 3             
  Total Devices : 4             
Preferred Minor : 0             
    Persistence : Superblock is persistent
    Update Time : Thu Mar 13 22:00:25 2008
          State : active        
 Active Devices : 3             
Working Devices : 4             
 Failed Devices : 0             
  Spare Devices : 1             
         Layout : left-symmetric
     Chunk Size : 64K           
           UUID : 55663848:a9ede020:1073524f:ba97c07f
         Events : 0.3           
    Number   Major   Minor   RaidDevice State
       0       3       65        0      active sync   /dev/hdb1
       1      22       65        1      active sync   /dev/hdd1
       2      33       65        2      active sync   /dev/hdf1
       3      34       65        -      spare   /dev/hdh1
I chrooted in the target directory from the debian installer but i could not get grub to install by hand as this is the output:
root@amaro:/# grub-install /dev/hd[b|d|f|h]
Searching for GRUB installation directory ... found: /boot/grub
The file /boot/grub/stage1 not read correctly.
(the [] means i tried all the devices but none worked).
The stage1 file exists:

root@amaro:/# file /boot/grub/stage1 
/boot/grub/stage1: x86 boot sector, code offset 0x48

and the device.map file is as follows:

root@amaro:/# cat /boot/grub/device.map 
(hd0)   /dev/hdb
(hd1)   /dev/hdd
(hd2)   /dev/hdf
(hd3)   /dev/hdh

I saved all the logs the debian installer gave me, they can be found at 


-- System Information:
Debian Release: stable
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: i386 (i686)

Kernel: Linux 2.6.18
Locale: LANG=it_IT, LC_CTYPE=it_IT (charmap=ISO-8859-1)
Shell: /bin/sh linked to /bin/bash

Reply to: