[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#470315: installation report -install ok but 1. x11 config fails

Package: installation-reports

Boot method: CD
Image version: debian-40r3-powerpc-CD-1.iso
Date: 02/21/08 23:02 ET (CD image file downloaded 02/19/08 12:51 ET )
Machine: MAC G4 PowerPC, Quicksilver 733 Mhz, uniprocessor
Processor: G4 (2.0) Boot ROM Version: 4.2.5f1 Memory: 256MB
Partitions: <df -Tl will do; the raw partition table is preferred>
Output of lspci -nn and lspci -vnn:

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot: [O]
Detect network card: [O]
Configure network: [O]
Detect CD: [O]
Load installer modules: [O]
Detect hard drives: [O]
Partition hard drives: [O]
Install base system: [O]
Clock/timezone setup: [O]
User/password setup: [O]
Install tasks: [O]
Install boot loader: [O]
Overall install: [O]

Comments/Problems: X11 problem; logfile below (Appendix B).

<Description of the install, in prose, and any thoughts, comments
and ideas you had during the initial install.>

A. Description of the original install

A1. Complex & slow installation
 Compared to a Mac OS X install, it took one hell of a long time and a lot of entries, this on as defaulted
an install as possible (no task changes).

A2. I didn't know what TASKS to select; I wanted to be sure X11 was included, but it wasn't clear how to get it.
(Added March 6: I've now scanned Unix for Dummies, and know that X11 is installed by default).
It got through the complete install, taking about 1/2 hour. I did a couple of other things while the longer
tasks were taking place.
Eventually it finished and said it succeeded.

The only obvious preset that I overrode was choice of network interface: it picked the first device (#0)
and the correct one was 1. THAT worked fine.

A3.I had a LOT of trouble entering a password AND DOING IT TWICE IN A ROW for ROOT. At the third or fourth try
(and beyond) I looked at the keyboard and not the screen to be VERY sure the right keys in my 18-character
password were being struck. They were - repeatedly. I'm not sure whether the problem was that
a. the password was too long, or
b. being slow, I was holding the keys down inadvertently, causing auto-repeats. The original and repeat
password screens being not visible at the same time, it wasn't apparent if this was a problem.

I eventually gave up the long password and stuck with an 11 or so character one, and it worked.

A5. After install, I immediately rebooted with root shutdown -r now, and the smoke test worked -- except for
an X11 problem. Rebooted again to OS X and that was also fine (holding down "x" key after chime).

A6. However YABOOT options to boot are mysterious:
a. entering <tab> shows two boot options,
Linux old

b. I assumed that entering the first letter of either would suffice; it does NOT.
c. entering <return> does boot Linux.
d. entering "Linux" does boot Linux.
e. I haven't tried entering "old".

B. Concerns
B.1 Backup needed for disk untouched by install?
I was somewhat nervous about whether install would clobber my Mac OSX disk.

 I even had just purchased a 2G stick to backup, and forgot to back up.
Only the intended Debian disk, ide1, was being touched by the install

So I wasn't very worried, just very careful to be sure the right partition was chosen to install on: an
 "unused" partition on ide1: set up under OS X. It was quite clear from the prompts in Debian Installer
 that the right one had been chosen, and all went as intended.
B.2 Having Debian pieces I couldn't use
I was somewhat concerned about buying the 4-DVD set, and as soon as I'd ordered one for 4.0r2,
not a day later did 4.0r3 come out, so I needed the Debian cd #1 anyway.

A lousy $8 cost for DVD's? why waste it, if I only needed the first CD?
C. Thoughts

C.1 Debian is an incredibly comprehensive system. I'm surprised it works at all, to the amazing credit of modern
programming teams, automated tools, etc. It still is far from being as automated as Mac OS X is, but then
neither is anything else... which is why I'll keep OS X around and only use Debian for my one, extremely
important, application, APLX, that requires it. (I don't have the $600 or so to buy APLX for OS X).

The process of bringing up and learning to use Debian is so difficult that I'm tempted -- not convinced yet --
to change from APL, or to change to Open APL, which I can recompile -- supposedly-- on any Unix system,
in particular under Mac OS X's BSD. (If only Mathematica were in the $ 100 price class -- non-recurring. Alas.).

C.2 Mouse might need setup: D.1.1. Setting Up Your Mouse, since I have a USB mouse (hung off my keyboard),
 it is SUPPOSED to be auto-detected. So long as that works, that is ....

D. In the bug report, describe what the problem is, including the last visible kernel messages in the event of a kernel hang. Describe the steps that you did which brought the system into the problem state.

There are is one fatal problem. It is compounded by documentation/help issues (2 etc.) 
D.1. X11 fails to configure

On boot into Debian, got this X11 error every time.

Looking at the Debian etch installation guide, I see:
B.4.13. X configuration: my video card configuration is standard for this Mac Quicksilver, but
not for Debian. I looked at the Debian Etch Installation Guide for Power PC,
B .4.13. X configuration
# X can detect the right driver for some cards, but if you're preseeding,
# you can override whatever it chooses. Still, vesa will work most places.
#xserver-org xserver-org/config/device/driver select vesa

I also checked X.org,
Ref: X.Org Wiki - XorgIRC

#6. Proprietary video driver support questions are off-topic. We didn't write them, we don't have
the source, and we can't fix them. Use #ati or #nvidia as appropriate, even if those channels
 appear to be dead too. ....
I also tried an older terminal with manually setting screen size and refresh rate to 800 X 600 @ 60 Hz.
X11 recognized the terminal and got much further through its startup, but still failed on not finding
 the terminal's size in its allowable configuration. I think this must be because the graphics card
isn't supported by Debian, so it confirms what it says in the Etch Installation Guide and X.Org.

D.2 Confusing documentation in Debian Etch guide vs X11 error message about what version of X11 to use

 I see the version of X11 used in Debian is 7.1, but the X11 error message says to try downloading
the newest version to fix the problem before submitting a bug report [on X11].

As you know, the X11 home page says they don't provide download files, "see your operating system provider".

D.3 What to do next?
D.3.1 Tried to Find out what is NOW in the X11 config file.
I tried to look at (print) /etc/X11/xorg.conf and it isn't recognized as a text file. No obvious switch
for PRINT to identify it as such.

Finally used NANO -B -L to edit the file with backup (!! NOT DEFAULT!) and throw away the new copy in case I
messed up anything. JUST SO I COULD READ the file!

D.3.2 How to FIX the config file??
D.3.2.1 Preseeding?
  I don't know about "preseeding" that -- I suppose I have to reread the Debian Etch Installation Guide
to find some clue(s) about how to do that, presumably before reinstalling. Ugh.

D.3.2.2 Just fixing it
The strong temptation is to edit the config file manually. This is scary - at least, it introduces changes
in an auto-generated file. So when I update to the next Debian release, POOF - changes disappear.
Ugh -- changes manually re-entered or system is broken again.

D.3.2.3 What info on modifying the file is already here? NOTHING?

The X11 config file comments say to do
MAN /etc/X11/xorg.conf

 It only typed the file CONTENTS, not MANUAL information. Further, in the wrong layout, with end-of-lines
 and wrap making it minimally readable).

D.3.2.4 ? Put in a BETTER, PROVEN autogen file
There happens to be a better AUTOCONFIG file generator for X11 from GENTOO. It is KNOWN TO FIX MY SPECIFIC
 X11 problem with my Quicksilver and its graphics board.

Don't yet know how / where to enter and run this program.

D.3.3 Ask for HELP!!

I joined the GENTOO forum and will ask how to set up and run their new X11 autoconfig.


 D.4.1 Put the GENTOO autoconfig generator into Debian. After all, it's another part of GNU.

Appendices: other info

Appendix 1: The graphics card IS standard for my machine.

GeForce2 MX
Type: display
Bus: AGP
Display Type: CRT
Slot: SLOT-1
VRAM (Total): 32 MB
Vendor: nVIDIA (0x10de)
Device ID: 0x0110
Revision ID: 0x00a1
ROM Revision: 1055


Resolution: 1152 x 870 @ 75 Hz
Depth: 32-bit Color
Mirror: Off
Online: Yes
Main Display: Yes
Appendix 2. X11 Logfile on failure

Since I can't cut and paste from Debian to OS X this is hand-transcribed and may contain
visual errors.

Failed to start the X server (your graphical
interface). It is likely that it is not set up correctly. Would you like to
view the Xserver output to diagnose the problem?

Xwindow System Version 7.1.1
Release date: 12 May 2006
Build Operating System: UNKNOWN
Cussent OS: Linux c-71-233-177-222 2.6.8-6-Powerpc #1
Mon Feb 11 09:42:25 UTC 2008 PPC
Build date: 24 January 2008

Before reporting problems, check http://wiki.X.org for latest version.
Module loader present
Markers (--) probed, (==) default setting, (**) from config file,
(++) from command line, (!!) notice, (II) informational, (EE) error,
(NI) not implemented, (??) unknown

(==) Logfile: "/var/log/Xorg.0.log", time Fri Feb 11 12.20.45 2008
(==) Using Config file: "/etc/X11/xorg.conf"
(EE) AIGLX: Screen is not DRI capable
(==) Logfile: "/var/log/Xlog/0.log", time Fri Feb 22 12.20.45 2009
(==) Using Config file: "/etc/X11/xorg.conf"
(EE) AIGLX: Screen 0 is not DRI capable
xkb_keycodes {include "Xfree86+altusers/qwerty"};
xkb_types {include "complete"};
xkb_compatibility {include "complete"};
xkb_symbols {include "pc(pc104)"};

0: /usr/bin/X/xf86 (Sighandler+0x94) [0x1008ebe8]
1: [0x100374]
2: [0x7F95880c]
/usr/lib/xorg/modules/libaa.so (XAAFillMono8x8PatternRectsScreenOrigin+00xdc) [0xf77d01c]
4: /usr/lib/xorg/amodules/libxaa.so (XAAPaintWindow+0x52c) [0xf78b090]
5: /usr/bin/X [0x010138764]
6: /usr/bin/X (miWindowExposures+0x328) [0x100e65dc]
7: /usr/bin/X [0x100a96cc]
8: /usr/bin/x (MapINDOW+0X3E4) [0x1002b6c8]
10: etc.

Fatal server error:
Caught signal 11. Server aborting.


Reply to: