[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#466713: Lenny SATA RAID Dual Boot Installation Report

On Wednesday 20 February 2008, Michael Altmann wrote:
> Comments/Problems:
> Installation goal has been a dual boot SATA RAID0 machine as playground
> for experimental software (i. e. Windows Vista ;-) and Lenny for real
> desktop work. I've followed the instructions of the debian installer
> SATA RAID wiki (http://wiki.debian.org/DebianInstaller/SataRaid).


> Problem: The installer fails installing a boot loader.
> Solution: The grub package from sid has to be installed in a shell:

This is a known issue not caused by grub itself, but by a regression in apt 
that should be fixed very soon.
Your workaround worked because you ran 'apt-get update', not because you 
added sid to the sources.list. The grub version from testing should have 
worked just as well.

> Problem: grub yields errors after calling "setup (hd0)" from grub
> command line
> Solution: link -s /boot /boot/boot

I've seen another report (#463483) that mentioned grub installation failing. 
The fact that adding that symlink works is an interesting data point.

Would it be possible for you to repeat the installation and uncomment the 
line "set -x" in /usr/bin/grub-installer _before_ running the bootloader 
installation step?
Please send the resulting syslog for the installation and the file 
grub-dmraid.log. Both can be found in /var/log/ during the installation and 
in /var/log/installer after rebooting into the installed system.

> Problem: dmesg and syslog flooded by "attempt to access beyond end of
> device" messages.
> Solution: Advice udev and hal to ignore the partition table found on the
> first disk.

This is beyond the scope of the installer, partly because the installer is 
not allowed to modify the configuration of other packages.

However, it would be great if you could document this issue and the solution 
on the DebianInstaller/SataRaid wiki page so others can benefit from it 

> Problem: /dev/rtc timeout on settig system time during boot up
> Solution: Append "--directisa" to HWCLOCKPARS in both hwclock.sh and
> hwclockfirst.sh

That's a known issue on some systems (see for example #277298), but again 
beyond the scope of the installer.

> Problem: Alsa complains an unknown device ALC882 at boot time.
> Solution: echo "options snd-hda-intel model=6stack-dig"

Also not an installer issue. I'd suggest filing a bug report for this in the 
upstream kernel bugzilla (), although you probably should check first if 
the issue still exists for current kernels (2.6.24).

> Problem: Some (not all) sound applications yields a crackling audio
> output.
> No solution so far. Hints found in the web regarding snd-hda-intel
> options like position_fix=1/2 or enamble_msi=1 didn't help.

I have the same myself. It used to be much worse for a while (see #437827), 
but I recently noticed that the problem is not yet completely solved or 

Thanks for the complete report!


Reply to: