[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#461110: please include packages from Priority: important

Package: tasksel
Version: 2.71
Severity: wishlist
Tags: patch

Please move packages from Priority: important to tasksel so that user has the
option to de-select them.

They could be put together with the "standard" task (as attached patch does)
or in a separate one.

Also attaching the patch that would be needed in base-installer after this


-- System Information:
Debian Release: lenny/sid
  APT prefers stable
  APT policy: (500, 'stable')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-5-amd64
Locale: LANG=ca_AD.UTF-8, LC_CTYPE=ca_AD.UTF-8 (charmap=UTF-8)
diff -ur tasksel-2.71.old/tasks/standard tasksel-2.71/tasks/standard
--- tasksel-2.71.old/tasks/standard	2008-01-12 03:37:36.000000000 +0100
+++ tasksel-2.71/tasks/standard	2008-01-16 17:52:39.000000000 +0100
@@ -2,5 +2,5 @@
 Section: user
 Description: Standard system
  This task installs a reasonably small character-mode system.
-Packages: standard
+Packages: important standard
 Test-new-install: mark skip
Index: packages/base-installer/debian/bootstrap-base.postinst
--- packages/base-installer/debian/bootstrap-base.postinst	(revision 50234)
+++ packages/base-installer/debian/bootstrap-base.postinst	(working copy)
@@ -80,6 +80,7 @@
 		cdebootstrap || debootstrap_failed=$?
 		log-output -t debootstrap run-debootstrap \
+			--variant=minbase \
 			--components="${COMPONENTS}" \
 			--debian-installer \
 			--resolve-deps \

Reply to: