[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#460471: CDROM Drive not reliable during install

Frans Pop wrote:
On Sunday 13 January 2008, Jessica Aldis wrote:
Boot from CD no problem at all.  During install it failed to
detect the IDE CDROM drive.

There are several possible reasons for problems reading a CD:
- hardware not correctly supported by kernel driver for your IDE controller
- CD not correctly burned
- CD has imperfections that cause read errors (cheap CD-RW?)
- hardware issues with the CD drive

In all cases it is not something we can fix in the installer itself (especially as you indicate that the tips in the manual don't help).

Following hints in installation guide
and so on, I disabled DMA and this helped a bit.  Flaky detection
and mounting of CDROM drive, but errors on reading.  Using the
all-generic-ide boot option gave easy detection/mount of the CDROM
drive but the same failure to read the CDROM reliably.

The all-generic-ide option is really only useful with SATA disk controllers. Given your processor speed I somewhat doubt you have one...

Failure is not immediate.  Some small stuff seems to be read correctly
from the CDROM.  From a shell (alt-f2) I can read the files on the
CDROM comfortably.

However, at that point you are probably not actually reading the files, but only the directory indexes, which is only a very limited read.

Checking integrity of the CDROM fails at about 60%, always in the
same file.  I've checked that file's md5sum on another computer
and it is not corrupted.

The fact that it is always on the same file would still suggest to me that it could be a hardware issue. Maybe the CD drive in your laptop is less tolerant of imperfections on the CD than your other computer is.

Have you tried burning a different CD? If not, I suggest you do that.

The Woody installation CDs I downloaded in 2005 work fine - I can
re-install Woody whenever I want.  Hence I believe the CDROM drive
is working properly.

There have been loads of changes in the kernel and in IDE drivers in particular. It may very well be that support for your (older) hardware is not 100% anymore. If it _is_ a driver problem, you should see the same issues after installing Etch as the installer does not do anything special to read the CD.

What I can suggest to try is:
1) burn a different CD-RW (possibly even from a different manufacturer) and
   try installing Etch from that
2) download an image for Lenny [1] and try installing that; if it is a
   kernel driver issue it could be solved in a newer kernel
3) install Woody or Sarge and upgrade to Etch from that; I'd suggest doing
   only a minimal install and to do the upgrade before installing a
   desktop environment;
   if you install Woody, you should first upgrade to Sarge and then to
   Etch; if you install Sarge, use the 2.6 kernel to make the upgrade to
   Etch easier

If you do 3), you can then check if you also have the CD problems with the installed system. If you do, the best thing to do would be to report them to the upstream kernel developers although they will probably ask you to first check that the problems also exist for a current kernel (2.6.23) as 2.6.18 is ancient from their point of view.


[1] http://www.debian.org/devel/debian-installer

Thanks for the this.  I appreciate the thought you've put into it.

I will do (1) as soon as possible. I'm pretty unkeen to try (3) until I have to, and my feeling at the moment
is that this isn't a driver issue so I'll leave (2) till last.

But I _do_ think there's an install system issue around DMA use for IDE CDROM drives in etch. A Google search hits lots of the same problem, in other releases. And all-generic-ide _did_ remove DMA
use from the CDROM driver _and_ did help.

An alternative that I prefer is to get the files from the install CDROM onto the laptop's hard disk, which I think I can do by physically installing it in another PC . Certainly less time
than downloading sarge for me.
Having done that, my idea is to boot and install as normal from the existing CDROM that I have. I know this will start to fail after the CDROM is mounted when files are being read from it. So after the install system has mounted the CDROM, I'll un-mount it and mount the hard disk, then symbolic link the install files on the hard disk to the install system's /cdrom and let the install continue
normally.  Do you think this could work?

J Aldis

Reply to: