[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#458663: Missing support for data.tar.bz2-based debs

On Wed, Jan 02, 2008 at 11:52:01AM +0100, Marc 'HE' Brockschmidt wrote:
> The current debootstrap code can't handle .debs which contain a
> data.tar.bz2 instead of a data.tar.bz. Attached is a fix.

Is it desirable for anything in the base system to use data.tar.bz2,
though? Relying on this would also require adding bzcat to d-i so that
debootstrap-udeb could use it; at the moment busybox doesn't build
bunzip2. I haven't tested, but bunzip2 isn't trivial so I expect that
the initrd size increase caused by this would be considerable.

What packages in the base system are trying to use data.tar.bz2 at the

Colin Watson                                       [cjwatson@debian.org]

Reply to: