[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#458459: Update "Installing from a UNIX/Linux system" for Lenny

On Tue, Jan 01, 2008 at 11:45:15AM -0500, Ian Turner wrote:
> On Tuesday 01 January 2008 06:59:23 Colin Watson wrote:
> > Why would the debootstrap-udeb package be required? debootstrap-udeb is
> > a special package that's only usable within the installer; normal
> > systems should use debootstrap. What problems did you encounter trying
> > to use debootstrap?
> I'm not sure why I thought it should be deboostrap-udeb, and I don't have 
> access to the system where I was having problems with debootstrap, so I'm not 
> sure why I thought it doesn't do the job.
> A bit of googling brings up a somewhat related question, however: Should the 
> install docs recommend debootstrap or cdebootstrap? See bug 254248.

They should continue to recommend debootstrap, since that's what the
installer itself uses by default.

The IRC log quoted in the last message in #254248 is incorrect or at
least very out of date; debootstrap is (now) actively maintained and
developed as part of the d-i project, and I think now has all the
relevant features of cdebootstrap. When cdebootstrap was written
debootstrap couldn't do dependency resolution, but that's no longer the


Colin Watson                                       [cjwatson@debian.org]

Reply to: