[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#440161: wrong /etc/fstab when installing on RAID using Adaptec 2100S

On Thu, Aug 30, 2007 at 12:38:50PM +0200, Arne Metzger wrote:
> I recently used d-i to install etch on a FujituSiemens Primergy F200. 
> That maschine has 6 SCSI-Drives built-in, which i have configured as 
> RAID5 (no Hotspare) using the Adaptec-BIOS. During POST and installation 
> the RAID-Array is shown as /dev/sda.

I am not familiar at all with I2O and don't have the hardware to
reproduce your issue, so we are going to need your help to solve this!

> Then i have created a ext3-Partition /dev/sda1 for /boot and a LVM on 
> /dev/sda5 using the rest of the Array-capacity for /.
> Installation proceeded fine.
> After rebooting the maschine, everything worked fine. System found LVM 
> and could mount it correctely, but then failed to mount /boot (which is 
> on /dev/sda1 - as i thought).
> I found out, that for the Adaptec 2100S the modules i2o-core and 
> i2o-block are loaded. The modules find the Adapter correctely.
> But my /boot-partition - formerly known as /dev/sda1 - could now be 
> found at /dev/i2o/hda1 after loading the i2o-modules.
> After changing the line in /etc/fstab from
> /dev/sda1	/boot [...]
> to
> /dev/i2o/hda1	/boot [...]
> and rebooting the maschine - it worked!
> Dont know, if that is a problem in d-i or in i2o...

After reading the I2O FAQ [1] it seems that the second path is only
accessing the first disk instead of the whole RAID array:

  What are the various modules for?
  I2O Block OSM (i2o_block):
  This is the disk driver, which let you access your RAID array, or if
  you don't have a RAID array configured to the single disks. You only
  have access to the disks through this driver!

  I2O SCSI OSM (i2o_scsi):
  This driver let you direct access to the disks. NEVER use this driver
  to mount a filesystem or so. If you do so, you could destroy your
  data.  Only use this driver, to monitor your disks for failure. You
  could use the smartmontools to do so.

The data for your /boot partition are probably out of sync now. :(

Does /dev/sda1 exists on the system?  What error message is printed when
you try to mount it?  Is there any strange entry that shows up in kernel
messages (dmesg)?

Jérémy Bobbio                        .''`. 
lunar@debian.org                    : :Ⓐ  :  # apt-get install anarchism
                                    `. `'` 

Attachment: signature.asc
Description: Digital signature

Reply to: