[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#436156: installation-reports: Inst report TP35D2-A7 (SATA difficulties)

reassign 436156 linux-2.6
found 436156 2.6.21-5
clone 436156 -1
retitle -1 rtc module loaded instead of rtc-dev
found -1 2.6.21-5
clone 436156 -2
reassign -2 xserver-xorg
retitle -2 PS/2 mouse not working

> The show stopping problem was that the installer failed to detect the
> SATA CD and the install ground to a halt.  I hooked up a PATA CD and
> the installation proceeded until it started to look for hard drives.
> Then it failed to find the SATA hard drives.  


> After a great deal of investigation I found that if I selected
> "legacy" mode for IDE in the BIOS then the SATA devices, both hard
> drives and CD were detected and the installer was able to proceed.

So this is indeed a kernel issue. I'm reassigning the bug to linux-2.6
package so kernel team people can check it.

> The motherboard hardware is an Intel P35 with Intel ICH9.  It appears
> from the listing below that much of the hardware is coming up as
> "unknown".  If there's some way I can help register my hardware let me
> know. 

Yes, there's. First is good if you run, as root: update-pciids

This will get the lastest version of pciids database so you can check
if someone else has done it already. If it was not, you can go to
http://pciids.sourceforge.net/ and follow the instructions how to
submit new data over there.

The supportt for your hardware, at least the IIDE controller, is
present on Linux source dates from 2006, part of linux 2.6.21-rc1,
check bellow:

,----[ GIT change that includes ICH9 PCI IDs ]
| commit f98b6573f190aff2748894da13a48bab0f10c733
| Author: Jason Gaston <jason.d.gaston@intel.com>
| Date:   Thu Dec 7 08:57:32 2006 -0800
|     [PATCH] ata_piix: IDE mode SATA patch for Intel ICH9
|     This updated patch adds the Intel ICH9 IDE mode SATA controller DID's.
|     Signed-off-by: Jason Gaston <jason.d.gaston@intel.com>
|     Acked-by: Tejun Heo <htejun@gmail.com>
|     Cc: Jeff Garzik <jeff@garzik.org>
|     Signed-off-by: Andrew Morton <akpm@osdl.org>
|     Signed-off-by: Jeff Garzik <jeff@garzik.org>

I didn't find your PCI IDs referenced on new PATA drivers...

> Once I got over this hurdle I partitioned my first hard drive without
> difficulty using the installer.  However, when I tried to get the
> installer to partition the second hard drive it seemed like it
> wouldn't give me the option of just having one big partition, so I
> gave up and partitioned that disk manually after the install.  

Could you please elaborate this a little more? I didn't understand
properly what you tried to do and what you had to do manually.

I don't understand if the second controller has been identified? If it
could be partitioned but not as you want or what?

> The hwclock command is broken which meant that any time I rebooted the
> clock would be set to some bizarre value.  The wrong fix is to add 
> HWCLOCKPARS=--directisa
> to /etc/init.d/hwclock.sh.  This at least gets it to work.  But I
> believe that the right fix is to get the module rtc-dev to load
> instead of rtc.  (I don't know how to do this.)  
> When hwclock is run with the system as installed this error appears:
> select() to /dev/rtc to wait for clock tick timed out
> If I unload rtc and load rtc-dev then it works properly.  

I've cloned this bug report but let it assigned to linux-2.6 package
anyway so we can track it down.

> When I got into X the mouse was dead (probably a fairly bad problem
> for a novice user).  The mouse is a Logitech LX3 that I had plugged
> into the PS/2 port.  I plugged it into a USB port instead and then it
> worked.  I modified xorg.conf to list the mouse device as /etc/psaux
> and then it worked in the PS/2 port.  (Note, however, that nothing I
> have found makes the tilt wheel work.)

I've cloned this bug and assigned it to xserver-xorg so X team can try
to sort it out.

> I have fairly new hardware.  If there's some way I can help improve
> the support of this hardware I'm willing to help.  

You've already done a very good step. You've reported the found issues.

        O T A V I O    S A L V A D O R
 E-mail: otavio@debian.org      UIN: 5906116
 GNU/Linux User: 239058     GPG ID: 49A5F855
 Home Page: http://otavio.ossystems.com.br
"Microsoft sells you Windows ... Linux gives
 you the whole house."

Reply to: