[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#427500: s390 Etch Install Problems level 2 guest LAN Error

Package: installation-reports
Version: Etch
When doing a network install of Etch under VM using
guest LANs for connectivity, the installation appears
to work fine untill re-boot. When the system re-boots
you get the error that level 2 networking is not
supported on VM Guest LAN. You get this message even
though you specify no level 2 networking during the
The problem is caused by the installer inserting a
line for level 2 networking in the startup file. I
found the following solution mentioned on the debian
system administration web site:

There is a bug in the layer2 config stuff I think. The
way I fixed it on an actual mainframe (not
hercules...so maybe its not the same issue.), was to
simply remove the line containing layer2 from
Once this was removed, I didn't get the corresponding
error you see at boot time and the network started
without issue. Until I made this change, I couldn't
see the hsi0 device through an ifconfig -a either. The
network also worked perfectly during the install, but
failed on the subseqent boot. I believe there may be a
place to set this in a config file rather than delete
the line that sets it in setup script, but its
location eludes me at this time. I hope this helps
someone else! I'll try to submit a bug report when I
get the time.

Editing the file mentioned and removing the level 2
line fixed the problem for me.

Rod Clayton
Amateur Radio Call KA3BHY
Columbia, MD 21045

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 

Reply to: