[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Problem booting Debian/NSLU2 after flashing

Dear Folks,

The short story:

After flashing my new NSLU2 with the latest Debian di-nslu2.bin
firmware, the device does not finish booting.  It seems to stop
with the amber status light, no beeps.

The long story:

I confirmed, of course, that the unit works under the native firmware.
I changed the network configuration to correspond to my local subnet.
I checked the MD5 sum against the posted one, unzipped, and flashed
(via wireless) using upslug2 to the di-nslu2.bin firmware.  After
packet timeouts, I attached my linux box via cat5.  The device flashed
and verfied followed by a reboot.  As mentioned above, it stopped with
the amber status light, no beeps.

After the first failure, I reflashed the unit using upslug2 and a
manual rest to the Linksys firmware.  Everything was then fine: the
web config was back with the IP that I configured originally.

I tried flashing (via cat5) using the web page method (as outlined in
the Debian/NSLU2 web page).  Still the same behavior ("hanging with
amber status light").

I followed the procedure to the letter, including pulling out the
devices prior to upslug2, I tried both hard disk (in a Venus enclosure
oxsemi chipset) and a usb stick, in the proscribed order and singly,
just to grab at straws.

One additional observation (may not be pertinent): I formatted my hard
disk with three partitions ext3, swap, ext3 for system, swap and data.
I noticed that the Linksys firmware sees my hard disk as "unformatted"
which seemed odd to me . . . I was tempted to try their formatting
(just to see) but I wanted my hard disk the way originally partitioned
so I didn't.

Any ideas?  I'm hoping it's simple . . . but I have no idea what else
to try.


Reply to: