[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

LVM2 + LUKS Installation Failure (netinstall) due to device-mapper


I have tried installing via netinstall CD (daily build - few days old, 
although it was the latest build as of yesterday), but if 
I select LVM2 with Encryption (LUKS), I receive the following error on the 
Partition section:

Partition disks
Configuration of encrypted volumes failed
An error occured while configuring encrypted volumes
The configuration has been aborted

In vt2, dmesg gave this output:
device-mapper: table 254:0 crypt: Error allocating crypto tfm
device-mapper: ioctl: error adding target to table
device-mapper: ioctl: device doesn't appear to be in the dev hash table

ls /dev/sd* results in a proper listing of partitions. I wrote random data to 
the hard drive, erasing the partition table, and the installer is still 
giving the same error.

dm_crypt module was loaded properly. The hard disk is a SATA drive. BIOS 
option for recovery partition is disabled, and was erased when I wrote random 
data to the hard drive.

Thank you.

Reply to: