[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#420181: Installation report 4.0 r0 "Etch" on IBM p5 510 inside LPAR

Original problems:

Initial boot:           [O] (only install64, install crashes on ramdisk init)
Detect network card:    [E] module ibmveth for virtual ethernet is missing
Configure network:      [ ]
Detect CD:              [O]
Load installer modules: [E] md5sum warnings, missing files

Problems are solved - media defective.

Of interest for users of VIO (via HMC or IVM):
I have found a way around burning a new disc (because I'm not physical near to
the machine): I downloded the iso onto the VIO server and putted it via dd into
a newly created virtual disc aka LV on the VIO. I attached this virtual disc as
secondary hard disc to the LPAR and booted the LPAR using the defictive cdrom.
After running into the missing files problem on initializaton of the installer I
remounted /cdrom from this second hard disc.

The installation went well:

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [O] module ibmveth has been loaded later on
Configure network:      [O] IP via bootp -> /etc/resolv.conf not set
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O] problem fs ext3 formatting, yaboot on LVM problem
Install base system:    [O]
Clock/timezone setup:   [O]
User/password setup:    [O]
Install tasks:          [O]
Install boot loader:    [O]
Overall install:        [O]

But I had some minor problems:

After the network configuration (IP send via bootp protocol!) the installer asks
for nameserver-ip and domain - correct. He is putting this information into the
target system (/target) but not into the installation environment. Thus
accessing the mirrors later on configuring apt fails.

I made several installation runs and only one time I could use ext3 formatting
of filesystems. All other runs (especially the last one...) I had to use
reiserfs because libblkid.so.1 was not found. I have no idea, what has gone
wrong - perhaps it is a side effect of my cdrom workaraound.

First I used "guided partitioning with LVM, whole disc" and as default the
installer puts the /-filesystem into the system vg. Then /etc/yaboot.conf is
inside of the vg and yaboot has obiously no access - message is "missing config
file or unknow filesystem".

Now I'm happy in having super small footprint and super stable debian running on
this machine! Many thanks to all who worked on etch!


Attachment: smime.p7s
Description: S/MIME Cryptographic Signature

Reply to: